Sandisk Ultra 128 GB connection problems


I’m having problems with my Sandisk Ultra 128GB pendrive. I’ll do my best to give as much info as possible:

The pc will recognize the USB drive being plugged in. Depending on the port (in case of USB 3) it will continuously (multiple times a second) plug in and out. Windows will give a popup if I want to format the disk every time (so if I live it in for a while my screen is filled with popups). Trying to format gives an error (makes sense as the drive disconnects continuously).

Plugging it in USB2 doesnt give an issue, until I’m accessing the drive for a couple of seconds. So I plug it in, all seems ok, windows sees the disk, I can check the properties etc. Then, when I acces the drive and try to copy something, about 90% of the time it freezes, and disconnects, and every now and then I can copy something or click some folders for a few seconds and then it freezes.

I’ve tried (without results): 

  • USB2, USB3, on 4 different windows systems (windows 7, 8, 10) and 1 Ubuntu system

  • reinstalling usb drivers/software for the disk (both through disk manager, and deleting/renewing the registry files

  • plugging it into my XBOX360, this one didn’t recognize it

  • formatting it through windows, and HP format tool (if it would work and the disk would work again I might be able to use some data recovery software)

I haven’t tried

  • reinstalling usb controller drivers (as I have the same problem on 5 different pc’s, and all the other USB devices work flawless)

There are some valuable files on it, that I was backing up, it started freezing during the back-up though so there is still some valuable data on it…

Anyone has any more suggestions?

Kind regards

You can try some of the Free recovery apps in the 3rd post in this thread:

If unsuccessful reformat the drive and return it, either to the seller or to SanDisk.

Thanks for the suggestion!

Recoveryapps don’t work (have also tried those already) as the pendrive shuts down the moment it get’s accessed for a few seconds. Same story for reformatting, gparted, windows formatting and hp usb disk format give errors just after the format starts :wink: