SanDisk Ultra USB 3.0

Got a SanDisk USB a while ago and have been having some issues with it. At first it seemed pretty good, 128 GB is plenty of storage. However later on started having some problems- when I was transferring some pics from my phone to the USB it started saying there were issue. Later on I decided to just go ahead and move those photo files to another USB because this one was no longer reliable, during the process which had hundreds of pics, the USB started freezing for hours. I eventually had to pull the USB out, and when I tried it again many of the files became like corrupted and ruined. Now every time I try to take care of this issue and plug the USB in it says “There are issues, scan and fix” but then when I click “scan and fix” it’ll say “this is write protected” then I tried looking up how to remove write protection on USBs but none of the methods have worked so far… I’m really not sure if I’ll ever buy a SanDisk anything from now on… Please help!

The drive is designed such that if there are problems it freezes all further updates so the files on the drive aren’t lost.

If you were loading all your pictures into SecureAccess that could well explain the freeze ups.  It wasn’t designed for that kind of load.  The pictures should be loaded to the drive along side SecureAccess’s vault.

At this point back up your pictures and return the drive for a free replacement.