SanDisk Ultra Fit Issues

Howdy Y’all. New to the forum, long time user of SanDisk products.

*Recently I was able to buy a SanDisk Ultra Fit 256gb USB drive. And *
let me tell you it was worth the pay for it. That was however until just this
evening.

I got a new-ish laptop, fully working and no viruses of any kind so I was
attempting to upgrade it to Windows 10. It said I could make a file on an
external USB so that I could upgrade other laptops, and as I sometimes
need more than one that was a bonus. But here’s where the issues started.

When I tried it, it downloaded and was creating it but got to 50% and got
an error, wish I had screenshoted the error. I looked it up, found nothing
of help then went to try and access my USB. Suddenly it was saying I need
to format it and yet I couldn’t. I’d used it for storing video files, movies, short
clips and the like and that segment was suddenly inaccessible, as was the
rest of it.

I went through 5 different methods, 3 different formatting softwares and no
success. I managed to partition, but then that even backfired on me because
I couldn’t access the damn thing either. So i removed the partition and it started
saying everything was write protected. I used command, regedit, formating
softwares both free and full copies. Nothing. I just about gave up and went to
another forum to ask for help. Whilst I did that, I incorrectly shut down the laptop
and then started in safe mode. Thought nothing of it, restarted again, and when
i ejected the USB properly and put it back it suddenly it was working. Not two
minutes after I posted about it.

Irony! But then I was an idiot and tried to make the same file again. Now I figured
it was something to do with safety mode so I tried again and it partially worked.

However the write protection seems permanent and nothing I try, be it program,
cmd or regedit will shift it or make it budge. One program got almost close, another
can’t do anything because it was ‘In Use’ I stopped that and it couldn’t do anything
apparently because ‘Fs is not supported’ so it can’t finish.

Now I spend usually hours on my laptop, I am no expert but I usually can either
solve or find out what’s wrong myself and yet here I cannot do damn thing.

Any advice would be helpful. I suspect I have just lost use of my UF USB
which is a shame but if that’s the case I’d like to know how to prevent it from
happening again. Irony of ironies I managed to upgrade to windows 10, it just
cost me removing a RealTek Bluetooth radio.

The Laptop is a Clevo, never heard of it until now but found out the model
and make, it’s a Notebook, Clevo W955TU. I have searched for hours,
quite literally I have stopped everything else I was doing trying to just get
it to work. If I get the chance and it can be fixed I will never use it for a trial
like this again. I was in two minds trying a second time, wish I had listened
to me self :sweat_smile: :man_facepalming:t4: