ULTRA FIT 32GIG USB DOESNT PLAY IN CAR

Hi i own a few usb flash drives all work fine in the cars usb for the radio till now , bought 2 of these drives as there small and also usb 3.0 so quicker to copy music to , both dont work in my ford or my wifes new nissan juke ? ive formated them fat32 etc but no joy in getting them to work properly , and googling the net im not alone , shame sandisk didnt find out this problem ? or did they and didnt care ?

1 Like

What do the car radio manuals say about USB requirements?  Size, format, file types, etc.

Does the Ultra Fit come with SecureAccess on it?  And if so did you put your music files in it’s vault?

hi it did but ive fully formated it , ive got other sandisk drives that work fine , bought this as its usb 3.0 and small , but if you look at comments on amazon theres others out there that say the same , just wish i read the comments first , but always had faith in sandisk stuff . ive tried fat32 and fatx and even tried different cluster sizes etc but no joy.

thanks

"ive fully formated it "

Unfortunately at that point it’s not a SanDisk problem, it’s yours.  What was manufactured, block size, cluster alignment, etc are gone.

Next time you want to delete files/folders on a USB drive use Windows Explorer to remove them, and delete them from the Recycle Bin should they end up there.  Or you could simply write your files along side the SanDisk files.  Formating worked with old simple USB drives years ago but this modern stuff needs a more caution approach.  IMO

LOL  its sandisks problem , havn’t you read my post , it didnt work firstly so ive formated various ways to try and get it too work and it still doesnt work , ive formatted all my other usb sticks countless times so stop trying to lay the blame else where , as i said just look on amazons website and read the feed back , cant believe your answer lol , makes me laugh , my sister owns here own software company and even she laughed her head off at your reply , its like saying to someone with a car omg you used sheel instead of esso petrol . The drive works fine just not in any of my cars and not in anyone else’s car all my other usb sticks work fine so i guess it must be because ive formated lol , and yeah ive used a few various different formating programs , im not some dumb blonde

" im not some dumb blonde"

So I see. :smiley:

" it didnt work firstly "

Sorry, I didn’t read it that way.  When you tried it firstly, did it have SecureAccess on it and did you add your files to it’s vault?

"stop trying to lay the blame else where "

Ok, my bad. 

" just look on amazons website and read the feed back ".

Well, there’s a problem with that, IMO.  1. People only post about things that don’t work.  2. The people that post about problems are usually a small percentage of the people that use a product.  And this is true whether we are talking about cars or USB drives. 3. When I buy things I usually go to a store to purchase them rather than buying them online.  Not 100% of the time but certainly the majority of them, and I don’t think I have ever bought anything from Amazon.  Thus I don’t see the comments you refer to and even if I did I would take points 1. & 2. into account.

So, let me know about the SecureAccess thing.  And if that was not the case know that you can return the drive to where you bought it.  I’ve heard that Amazon is good about returns.

It would be interesting to hear from anyone who has one of these drives and has used it in their cars successfully.   

yes left the stick as it was and transferred the music over to it and no joy , the problem is the music plays at a weird high speed , stopping and starting , tried various different quality mp3’s and bit rates and still no joy, so did a bit of googling and found i wasn’t the only 1 so thought id do a bit of trial and error and different formats and used verbatim fat32 format program and hp format program , still no joy , tried different cluster sizes and still no joy , sat in the car with laptop trying different ways etc as really wanted to see if i could find a solution but accepted defeat in the end . ive ordered a aluminum strap for it now and will just use it on my keyring , there cheap as chips so no big deal just a shame. i think the size will appeal to alot of people who want to fit and leave them plugged into there car stereo’s

:smiley:   Hi Roger,

Please, can you answer the question, of the message N° 2, of a concise and clear manner?

Thanks.

Regards, Alfred.                                                     (Google Translated)

Hi there,

Guess what: I’m having the exact same problem with teh exact same USB stick… And I also bought 2 of these for my wife and myself.

In my wife’s Juke, it won’t even recognize the USB stick.

In my JVC autoradio, it plays the mp3 songs with crazy audio skipping and jumping to next song every few seconds: unusable.

I’ve also tried all kinds of formatting options with no luck. Even the standard FAT32 with 64k clusters doesn’t help with this Sandisk stick, although it’s always worked fine with other USB sticks in my cars.

Looks to me it’s some strange issue linked to the Sandisk hardware, maybe a power issue.

In case I find a solution, I’ll let you know. Please do the same if you find out a solution.

Thanks,

CHGR

:smiley:   Hi Chgr,

Dear member of SanDisk Community, welcome.

Please, check the manual of your device, in the specification section, the compatibility with USB 3.0 UFD, with exFAT, with maximum storage capacity, etc.

For more certainty and for other ideas, also you can send the question to the Support Team: http://kb.sandisk.com/app/ask/

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                           (Google translated)

 

Hi

I have same problem, i buy a sdcz43-032g-g46 ultra fit 32gb and dont wort in my car too. I try with original format, try with FAT32, NTFS, and exFAT and none of them work. put only one song on it without folder and still doesent work, i have and old 16gb sandisk cruizer fit and it work fine with same music on it.

I have other flash drive Corsair go 32gb and works fine too.

If you found a solution to this problem i whant to know too.

Just for me, I’d check with the provider with your car audio. They will know which flash drive will be compatible. Or if you need to format it in a specific file system.

Hi,

Actually I gave up with the SanDisk Ultra Fit.

I bought another stick (Transcend JetFlash®710 USB 3.0 32GB) and it works fine in my car with my 2009 JVC unit.

The Transcend stick doesn’t work in my wife’s Nissan Juke built-in stereo even though it’s more recent than my JVC, but I was able to use an older 16GB stick that works there.

From what I’ve read elsewhere in forums and from the car documentation, it’s not a matter of incompatible specs or format, it’s just luck or no luck with the hardware. Car USB compatibility seems to be a rather tricky matter.

Thanks anyways.

CHGR

i was waiting for them to blame the car etc , so why is it i have about 4 or 5 different sticks most being sandisk and they all work , as i said amazon has others on it with same problem , sort it out sandisk , ford is a popular make so its not to hard to take one out to the staff car park and try . Every time i see these on hotukdeals or amazon etc im gonna post avoid if for car use

You should do that for all car ads also. :wink:

I’m wondering if this has to do with USB 3.0 specs.  I have read that they are not as nailed down as the USB 2.0 specs.  Thus a USB 3.0 device and a USB 3.0 port could be a bit out of sync in some cases and thus not work together.

I have exactly the same problem and it doesnt just skip through music on my car radio, it skips through music no matter what I plug the stick into - laptop, xbox, macbook, desktop, bluray player.  It skips through music. So by that reckoning its not my devices its a problem with the Pen drive.  I got this primarily to play music in my car.  It cant do that.  I’d like to know why

Many thanks. 

Based on those efforts dezzie I agree it’s something wrong with the USB drive.  A dirty/oxidized contact, a bent contact, which may or may not be fixable.  If fixable great, if not return the drive, either to where you bought it or to SanDisk would be my suggestion.

I’m afraid you are mistaken.  It is Sandisk’s fault.  If there drive doesn’t play in multiple vendors head units, then it’s their problem.  If the 2,0 version works fine, it’s their problem.  Because it is “suppoedly” backwards compatible.  Don’t blame the user.  Blame the source.

@ed_p wrote:

Based on those efforts dezzie I agree it’s something wrong with the USB drive.  A dirty/oxidized contact, a bent contact, which may or may not be fixable.  If fixable great, if not return the drive, either to where you bought it or to SanDisk would be my suggestion.

I ordered two from Amazon, and they both performaed the same.  Skipping thruout. Evewn if it is USB 3.0, it is supposed to be backwards compatible. I have a Lexar 64gb USB 3.0 that works fine.