SanDisk Ultra Flair USB 3.0 64GB freezes

Hey, today I was working perfectly on some documents for college work and randomly my Microsoft Word showed “I/O Device Error” or something like that, I then made sure the work was saved either way and everything was good. The document closed about a minute after and I decided to re-plug my USB. Since then, every time I plug my USB into my PC or anybodies PC then it freezes everything. I’ve tried using EaseUS Partition Manager to see the partition but the program freezes as soon I put the USB into my computer. On top of this, I’ve tried using diskpart via CMD (ran as Admin) and it won’t load the diskpart list until the USB is removed (once again, it crashes, won’t display the USB’s partition). When the USB is plugged in, sometimes it doesn’t fully freeze my windows explorer but it shows no capacity of the USB and if I try to right click it, it doesn’t work it just freezes my windows explorer.

What do I do?

I have the same problem with a Extreme PRO USB 3.1 256 GB.


Sounds like you need to return it for a free replacement.

or talk to a tech support rep.