USB Device Not Recognised - Sandisk Extreme USB3 64Gb


I have a 3 month old Sandisk Extreme USB3 flash drive (64Gb) which until now has been working perfectly.

If I plug it in now to a USB3 or USB2 drive, I get an error message that the usb device is not recognised and that it has malfunctioned.

With regards to plugging it into a USB2 port, that is as far as I get as the drive doesn’t appear in Windows Explorer.

If I plug it into a USB3 port, I get the error message but about a second later the drive appears in Windows Explorer and I can access the files as per usual.

I have tried this on 3 computers and the same thing happens.

I have searched the forum to see if anyone else has had this problem but couldn’t find anyone (err I’m not very good at searches though).

Any ideas?



:smiley:   Hi Paul,

Dear member of SanDisk Community, welcome.

Friend, please:

Inspect with a magnifying glass and a flashlight, the USB 3.0 plug of the UFD, and clean the pins,

with wire or eyebrow tweezers, etc., and with isopropyl alcohol (or also medicinal).
Also try, with a can of “compressed air” and a paintbrush, etc.

Check that the pins (Standard has 9 pins, 7 for USB 3.0 + 2 for USB 2.0), are not dirty, bent or broken,

or simply not fit as it corresponds.

If the above steps have not solved the problem please, back up your data and contact SanDisk Technical Support 

who will replace the device if it’s authentic and is within warranty.


Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                             (Google translated)

How about doing a Windows Update? It’s one of the ways to update the driver and could fix this for you.