HELP! SanDisk Extreme 16GB - "USB device not recognised" error message


SanDisk Extreme 16GB USB 3.0 Flash Drive


Windows 8.1 Pro 64-bit


Used for over 12 months. One day it decided to give me the dreaded “USB device not recognised” error message in the bottom right hand corner of screen. Drive letter missing. Blue light on flash drive is ON.

  • Connected to every USB port on PC (2.0 and 3.0) - same error message and no drive letter.

  • Connected my various collection of USB flash drives to any of the USB ports on my PC - result OK working.

  • Connected Extreme 16GB to another PC - result same error message BUT can see drive letter and see data.

  • Decided to format and install a fresh copy of Win8.1 alone nothing else. All other HDDs disconnected. Result is same error message and no drive letter.

Any ideas?


No idea what the problem could be let alone the fix.  Return it and get another.

Since it has been working before, try to check first if it’s a driver problem. Have you tried plugging this in on a different computer? Try also a Windows System Restore if you don’t have another one available.