Weird problem with SanDisk Extreme 64 after safately removing it.

Hello Guys!

Hopefully some one here can help me with a weird problem that I am having with my brand new flash drive.

Machine and Drive Details:

Laptop: Dell Latitude E6330

O.S: Windows 8.1, 64 Bits

SanDisk Product: San Disk Extreme 64GB Flash Drive

Problem:  Windows recognizes and detects my flash drive fine but it won’t detect it anymore after safately removing it and re-inserting it. I have to fully restart my computer (with the flash drive in) in order for Windows to recognize the flash drive again.

Error Messages: None, no error messages, it simply won’t detect it, it looks like the power from the USB Port goes “down” after safetely removing the flash drive.

What I had tried:

1: I tried my SanDisk Extreme with another USB port that is located at the back of my laptop (the same laptop) and it works fine, no problem at all.

2: I tried my SanDisk Extreme with other laptops and it works fine too.

3: I tried with a different (brand) flash drive and it works just fine on the same laptop and same USB Port.

What could be wrong?


Check out this thread and the links within it.

There is also the possibility Windows has assigned the same drive letter to another device.  Manually reassign the drive letter and see if it helps.

:smiley:   Hi Jcroot88,

_ Dear member of SanDisk Community, welcome. _

Okay, did you do all the tests, I would do in the first stage.
So, I think what happens, is that was a corrupt line, in the registry, which detects this UFD as “problematic”.

1- Then, the easiest to clean the “USB junk” , you can use (portable, 64b, free):

USB Scrub Cleans 1.00,

2- If not resolved, check if you have a “System Restore point” immediately previous, to the problem.

3- Finally, would the manual removal of the corrupt line, in the registry, but it is very risky:

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                            (Google translated)

The USB scrub is asking for a password to expand the rar file.  Anyone have the PW

:smiley:   Hi Jncal,

1-   The pass is: 123

2-    Try: CCleaner 4.15 [P], (Pass 123),

3-   See also, in the Task Manager, the processes which are running, and see what are the necessary and what to delete.

Because, there are some services programs, telephones and video cameras, that cause system conflicts, by interference in USB ports, such as: Samsung Kies, HTC Sync, Sony Play Memories, Motorola, etc.


Regards, Alfred.                                            (Google translated)