Extreme USB 3.0 Flash Drive does not Recognize Properly by Windows 7

My Extreme USB 3.0 device (SDCZ80-064G) is not recognized properly suddenly today in both of my laptops with Windows 7 x64 installed.  Both Vaio & Lenovo have USB 2.0 and USB 3.0 ports, which Vaio expanded USB 3.0 ports by adding ExpressCard Adapter.  My Extreme USB flash drive was formatted in NTFS file system and worked smoothly until yesterday.  I have tried to plug the flash drive into USB 2.0 & 3.0 ports on my laptops many times, the blue LED does not illuminate instantly anymore during Windows detecting the drive as usual. 


Both laptops do detect the flash drive, but it is recognized as “USB Device” instead of “SanDisk Extreme USB Device” in Device Manager.  Its show the device as “Fujitsu MB86C31” instead of “SanDisk USB Flash Drive” at “Devices and Printers” in Control Panel.  Also, both OS mounts the drive as “Removable Disk F:” in Disk Management showing no media, and appears the same as in “My Computer”  When I double click onto the disk under Windows Explorer, a notification window pops up, which stated "Please insert a disk into Removable Disk F:”.


I could not format the Extreme flash drive under Windows Explorer, Disk Management, Diskpart in cmd prompt, and 3rd party low level format software.  I have changed the drive letters couple times to avoid conflict.  Also, I have manually located the driver within the OS, cleared hidden devices and make changes to the Registry following the instructions on SanDisk supported website - http://kb.sandisk.com/app/answers/detail/a_id/139/kw/flash%20drive . However, all of the works above do not fix the problem!!!  Please refer to the pics links for details. 


I know that my flash drive is mostly unfixable, however, there are some important data that I need to recover from this drive.  Therefore, I would really appreciated if anyone can provide me any solution to fix this problem.




To retrieve your data, just find a data recover company or store in your city, as your flash drive cannot be recognized on your two laptops. I remember that SDCZ80 flash drive is a lifetime warranty product. Try to send a email to SanDisk and tell them this problem, maybe they could change a new one for you.

It’s the Windows drivers that it depend on. Try to do a Windows update and see if it works.

One of the USB drive error is “Please Insert A Disk Into Removable Disk”. This error occurs because your Windows OS has already assigned the name of the removable drive letter with other drive or hardware of the system. You have to change the drive letter name of the removable drive and thereby you will not have such problems. Here is the step by step guide how to do this to fix this error - http://www.rescuedigitalmedia.com/fix-usb-drive-error-please-insert-disk-removable-disk