SanDisk Extreme Not Recognised In USB 3.0 Port

My recently purchased 64GB Extreme is not recognised when plugged into my laptop PC’s USB 3.0 port.

It works fine when plugged into a USB 2.0 port but that’s not what I bought it for.

Very occasionally when plugged into a USB 3.0 port it will show up for a minute or two but then disappears again. 

There is no message displayed to say it’s not recognised nor is there any indication of any sort in Device Manager. It just isn’t there.

Is there any way to resolve this problem?  

I am using Windows 7 64-bit.

update driver for USB 3.0 manually

I’ve already done that. Didn’t make the slightest bit of difference.

When I plug my USB 3.0 external hard drive into the USB 3.0 port the SanDisk Extreme was in it works perfectly. Take it out and put the SanDisk back in  … nothing.

Clearly the problem is with the SanDisk Extreme and it’s USB 3.0 compatability.  (As I mentioned above, when it is plugged into a USB 2.0 port it works just fine).

Saw this thread from January. My extreme 32GB was working fine yesterday. This morning it’s not recognized as a USB 3.0 device on 3 different (nearly identical) PC’s. Nothing has changed so I’m mystified. Works fine as a USB 2.0 drive.

The original poster never updated this thread, so I don’t know how – or if – he solved his problem.



I have this same problem with my extreme 32Gb and although its not really a fix, I have found that pulling it out of the socket slightly seems to make it work .

Therefore think this is probably a design fault with the connector, although it does seem that once it’s recognised, it can be pushed in properly again.

1 Like

I heavely relies on Windows drivers. So if Windows did not recognize it, I would make sure to check the Windows Updates first. 

Therefore think this is probably a design fault with the connector, although it does seem that once it’s recognised

I can think of other possible causes:

heat

cold

bent pins

cigarette smoke on the USB port

oxidation of the USB port

loose wire on the USB port.

I have at least one USB port in the back of my desktop machine that I periodically have to touch with emory paper to get it to work normally again.

Additionally, if you want to double check this. Try it on another computer with a USB 3.0 port and see how it behaves. 

Thanks for that tip.  That did the trick for me.  I remove it completely then push it in very slowly, when I see the light light up, I hear the windows tone, then my sandisk is recognized. Then I can push it in all the way and it will work until I unplug it.  Definitely sounds like a design issue or hardware flaw on my usb drive

1 Like

Same issue here. 32GB SanDISK Ultra. Not recognized in laptop nor PC. It used to work for a while.

By the way. Both USB controllers are no Windows ‘default’ or anything of that kind. Hardly any USB 3 ports are. The older Sandisk, don’t know the type, it’s as big as my thumbs top, works flawlessly and always has.

What’s up next? RMA? Wouldn’t look good if it isn’t I guess. Anyone?

RMA is certainly an option.

https://kb.sandisk.com/app/answers/detail/a_id/5232/~/return-material-authorization-(rma)-process

Yes indeed, when the sandisk stick is inserted completely inside USB 3 Port (works fine to USB 2 ports) is not recognized by any windows and also not even from bios of any computer generally when you want to boot from the USB stick to install or run anything.

But is detected and works fine when is not completely inserted inside.
I suppose too is a design mistake.

yes it worked for my  USB hub 30 by oicent push it light comes on then goes out .  back it out of the port and it connects 

but other brands of USB Flash 20 don’t have this problem with my hub…   Thanks for  workaround   Shame  on sandisk Testing lab