Extreme 32GB detected on USB 3.0 but not USB 2.0

Hello everyone,

I recently bought a Sandisk Extreme USB 3.0 32GB flash drive.

First, it seemed to work fine, however some time I discovered something very odd.

When I plug the flash driveon a USB 3.0 port it works just fine but when I want to use a USB 2.0 port, the key is not recognized but my computer.

On Windows 7, it doesn’t appear in the device manager.
I tried Ubuntu, with no more luck, and worst, even in the BIOS the flash drive is not detected ! Again, when plugged in USB 3.0 I see it everywhere. I also tried 2 other computer with the exact same results.

This issue is really annoying because some of my computer do not have USB 3.0 port, therefore I cannot use my flash drive on them.

Does anyone have any idea of what this problem is ?

:smiley: Hello!

Well, seems defective, you must return it.

But as you can do the following test: the USB 3.0 UFD have 9 Pines (contacts) and 4 pines are for USB 2.0 compatibility.

Then you check with a magnifying glass and flashlight if these Pines are dirty or broken or bent.

In Wikipedia you can see a graph with the provision of these Pines and which are 3.0 or 2.0. Luck.

Regards, Alfred. (Google translated).

Hi, and thank you for your answer :wink:

I re-sent it back to Amazon, because I think you are right and one of the 2 pines used by USB 2.0 is broken.

FYI, there are 5 pines dedicated to USB3.0 data, 2 for USB2.0 data, and 2 for power supply.