SanDisk Extreme Drives Stopped Working

OK, this is so bizarre. I have three Extreme drives, two of 32GB and one of 64GB.Been using them for a couple of years.

I copied some video files from one PC (Win 10 x64) to one of the 32GB drives, then took it to another PC (also Win 10 x64) and copied the files to the hard drive. 

Here’s the creepy part: Ever since that last copy succeeded, none of the drives work. They are not recognized by any of my three PCs, they aren’t recognized as a device in Disk Management, they don’t show up as a drive in the BIOS. The indicator light comes on when the drive is inserted in the USB port. No “Windows Sound” is heard. 

It’s like they all got struck by lightning at the same time.

I’ve gone round and round with these for the past couple of hours trying to figure out how in the world all three could fail at once. 

This one has me stumped.

1 Like


I tested all of my flash drives in all three PCs.

  • All of the USB 2.0 drives (regardless of brand) work in all of the PC’s, both in USB 3.0 ports and 2.0 ports.

  • All of my USB 3.0 Docking stations (Orico) work in all of the USB 3.0 ports.

  • 2 of my SanDisk Ultrafit USB 3.0 drives work in all of the USB 3.0 ports on all of the PC’s. One of these has seen occasional use, the other was brand-new, fresh out of the package. The third drive fails in all ports.

  • NONE of my Extreme Flash drives (two 32 GB and one 64 GB) work in ANY of the USB 3.0 ports on ANY of the PCs. One of them works in the 2.0 ports, but cleaning, reinitializing and reformatting did not succeed in making it USB 3.0 compatible.

  • I have two Extreme card reader dongles for my SD cards. One of them is old and the shell had cracked open. I bought a new one a few days ago to replace it. The OLD one still works in all USB 3.0 ports. The new one (right out of the package) doesn’t work in any of the 3.0 ports.

  • I have the latest BIOS and Chipset drivers in all three PCs, installed prior to the problem. The failed drives do not appear as available in the BIOS setup (no surprise there).

The failure of the drives was signaled by no activity as far as I can tell. I transferred a few large HD video files (10 GB+) from one PC to another successfully on my 64GB drive. A few hours later I tried to do the same action and it wasn’t recognized by either the source PC nor the target PC. I then tried all of my Extreme drives and non of them worked.

As I noted in my original message, this problem defies logic. It’s like a neutron bomb exploded and targeted only SanDisk 3.0 drives.

I’ve been working with computers for 25 years and have seen plenty of strange things, but this is right up there with the strangest.

Any useful suggestions are appreciated.

“cleaning, reinitializing and reformatting did not succeed in making it USB 3.0 compatible.”

In that those things have nothing to do with USB 3.0 not surprising.

"I’ve been working with computers for 25 years and have seen plenty of strange things, but this is right up there with the strangest.

Any useful suggestions are appreciated."

It’s possible your power has encountered a blip effecting each of the pcs.  It was 120v now it’s 110v.  It’s possible there was a power surge which impacted the pc’s power supplies.  It’s possible the vendor of your pcs issued a USB update.  It’s possible Microsoft issued a USB update.  It’s possible smoke, soot, dust oxidized the USB 3.0 contacts on the pcs USB 3.0 ports.  (I actually have an old pc where once a year or so I have to clean it’s USB 2.0 port with emory paper to get it to work again,) 

Thanks for the reply, Ed.

In order:

  • System is fully protected by a 900va UPS. And it’s a 230v system, currently at 227v. Log shows no power blips for 2 months.

  • All three PCs had drivers updated in the past month, prior to the problem. I checked with the vendor and they have issued no new updates.

  • Motherboard is new and was installed last November. It’s kept in a clean environment.

I’m willing to believe it’s a motherboard problem, that every time I inserted a USB 3.0 drive it somehow caused a fatal hardware problem on that device, yet USB 2.0 devices were unaffected. In order to test that theory, I need a working USB 3.0 drive that I’m willing to sacrifice. Then, if that proves out, I have to make a leap of faith and replace a 6-month old motherboard hoping that the problem disappears. Not to mention replacing the failed drives, unless SanDisk will replace them (something I seriously doubt).

Unless you see any further ways determine the exact cause, I don’t see that I have much of a choice.

I finally got the motherboard replaced with the same model, and the problem disappeared. Very, very odd to see the USB 3.0 ports in such a serious fashion.

Thanks for the update hurricane51.  Good to hear the thread has a happy ending. :smiley:

My extreme is strong still haw 100 wear level vs others whit tlc. Life time waranty is good staff

But theh is no software to restore to coplete factory defoults.

Ummm, I’m trying to figure out what your message has to do with this thread. 

I have a SanDisk 1T and a SandDisk 2T that both stopped working on my Dell 27" All In One computer running Windows 10, USBs 3.0.  Interestingly, the both SanDisk external drives worked on my Lenovo laptop and my HP All In One Computer running Windows 7.0, 2.0 USB.  A friend of mine told me to try a different cables; in other words, cables other than the ones that originally came with the solid state external disks.  Voile!  Both worked with other cables…!!  Who knew?  

!! Wow!!  Thanks for the update.