SanDisk Extreme not working in USB3

I own a SanDisk Extreme USB3 16GB drive for past one month and now I’m in a strange problem.

The pendrive doesn’t work in USB3 ports. If I plug it in USB2 ports, it works flawlessly but with limited speed of around 28-30MB/s which is capped by USB2 specs. If I plug it into any USB3 port, the computer doesn’t even sense something plugged in. No cling/clang sound from speakers or any changes in device manager. 

I have a USB3 HDDwhich works at USB3 speeds in the same USB3 ports so I don’t think any problem with my PC/Laptop.

My PC  has ASMEDIA USB3 port and laptop has AMD USB3 port.

This usb drive was my best drive because it gave speeds over 150MB/s while copying… but now I cant use it in USB3.

Is there anything I canm do like firmware etc. to make the drive work in USB3 port again.

So the drive initially worked in your USB 3 ports but now it doesn’t?  Did you reformat the drive?  Did you update any drivers on your pcs?

The driver for that USB3 device might not be properly installed. When you plug this on a USB3 port and open Device Manager, can you see a yellow question mark on the USB section? If yes, try to run a manual windows updates and see if that will help out. 

It worked fine in USB3 earlier.

Today I found it to be connector issue in the pen drive. For USB3 ports I have to pull it a bit(very small) after inserting in USB3 port and it works in USB3.

It could be the USB port itself.  I have one on a desktop machine that fails about once a year and the fix is to touch it up a bit with emery paper.  Then it works for another year or so.

Contacts oxidize, get dirty from dust & smoke, etc. 

OMG this is my exact problem too. purchased and use it on a brand new laptop, and a short while after installing my antivirus program, and after upgrqading to windows 8.1 it started acting up, and not being recognized on this PC, and I thought I had screwed something up, because it would work fine in any other PC. But after I read your second post about pulling it out just a hair, mine was immediately recognized. I dont think there is anything wrong with our pc’s now, I think the device is just not making contact when we push it in all the way on our particular machines. Thank you for posting your issue because I have been racking my brain to figure out what is going on.

If the guru’s want to check this out and see if it is a problem with particular hardware, my laptop is a Dell System Inspiron 17 7000 Series 7737 with USB 3.0 ports.

Exactly the same problem, tested on several computers with USB 3 port with the same behaviour.

It’s not a driver problem but something wrong on the key, if you connect it on USB2 port that work.

I think this usb product is very fragile, it’s my second issue with two different key.

What we can do to solve the issue?

:smiley:   Hi Vincemiquel,

Dear member of SanDisk Community, welcome.

Well, with a powerful magnifying glass and a flashlight, review the USB 3.0 port of the PC, and plug of the pendrive.

Check, that the pins (Standard has 9 pins, 7 for USB 3.0 + 2 for USB 2.0), are not dirty, bent or broken, or simply not fit as it corresponds.

----------------------------------------------------------------------------------------------     

USB 3.0 Standard "A"

Pin     Color       Señal                       Description

1         Red         VBUS                       Power

2         White       D-                             USB 2.0 differential

3         Green      D+                            USB 2.0 differential

4         Black       GND                         Ground for power return

5         Blue         StdA_SSRX-          SuperSpeed transmitter differential

6         Yellow      StdA_SSRX+         SuperSpeed transmitter differential

7         Shield      GND_DRAIN         Ground for signal return

8         Purple      StdA_SSTX-           SuperSpeed receiver differential

9         Orange    StdA_SSTX+          SuperSpeed receiver differential

Shell  Shell                                         Shield Metal housing


Enjoy, and then you tell us, what happened, please.

Regards, Alfred.                                                                (Google translated)

Thanks for your answers Cacho :wink:

Unfortunatly the key has passed away, second times for me, no longer guaranty

I will take an other company for the next.

Vincent