Sandisk Extreme USB 3.0 32gb Slow copy and read speed

Hello Support Team,

I was shocked to see all of a sudden my usb 3.0 pendrive showing lack in performance with a write and read speed of not more than 40mb/s

I tried different usb ports and tried variety of file even crystal benchmark confirmed the same.

I dont know what to do.

I can enjoy the extreme speed now. Please help. I already raised support question but still no feedback from them

This forum is not monitored by the SanDisk Support Team. This is a user’s forum. If you have already contacted SanDisk Support, they will be the best qualified to answer your question.

But just from my very limited knowledge, just because you have a 3.0 flash drive does not guarantee you will see faster speeds. You also need 3.0 USB ports and card reader.

all of a sudden

What changes have you made to your system lately?  New apps?  New updates to existing apps?  Updates to Windows?  Where was drive used prior to the problem appearing?

Hi there,

I think I have the same problem. Sandisk Extreme 32 GB pendrive, Dell E6430 USB3 notebook.

In the first two weeks my pendrive was super fast and working well, then one day it became really slow. Read is still quite fast but I cannot write large files on it, as transfer rate stucks at 5-6 MB/s, which is far below acceptable. For the first 1-2 seconds, write speed (shown in Total Commander) is over 150 MB/s, then it declines fast and continuously to 5-6 and stays there for the whole time. I don’t really understand.

I tried to reformat it in different ways (FAT32, NTFS, exFAT) but nothing changed.

Any solutions or ideas?

Any solutions or ideas?”

Ideas:  A Windows update.  An antivirus update.  Indexing enabled.  A compressed file on the drive being repeatedly scanned by a security app.  Nicotine on the contacts.

I have the same problem and i have used it on several brand new pc`s at my work (IT-admin) and this usb is the slowest USB ever even slower than old usb 2 ones. I never us it any more beacuse i dont have time to wait. I registred to this forum only to say that this produc is not whort it.

Does the drive come with SecureAccess and are you using it?

I believe it’s partially due to the SSD architecture it uses. Extreme 32GB flash drive works like a SSD without TRIM (while most conventional USB flash drives do not use so complex controller logic like this). When new, all blocks are considered free so writing speed is high. However, after writing, all written blocks are considered containing data, leaving less and less free blocks. When 32GB data has been written accumulately, no matter how much file data remains on the drive, there will be no free blocks left. There will be a small percentage of blocks used as overprovisioning, say 7% for example. After the overprovisioning space is used up, further writing will meet blocks containing existing data. Thanks to the existence of the overprovisioning, those blocks may be partially full (for example, I have a file A, and I overwrite part of it, then the data overwritten may be saved into further free or partially free blocks, possibly overprovisioning space, and the original blocks containing data of A become partially free). Then, when write goes on, those partially free blocks will be merged with new data to make a full block. But since flash memory writes use blocks as a unit, there will be a “read block, merge data, write block” cycle, making the performance poor, such as the 5~8MB/s as seen (in my own case, its 3~7MB/s :frowning: ). That’s my explanation to the performance issue.

However, I wish that there is some software way to “reset” the drive, even clearing all the data, this is still acceptable for me. I’m contacting Sandisk support now.

Continuing the discussion with newest update: I contacted Sandisk support, and their reply suggests doing a complete reformat (rather than my previous quick format). I tried that, with Windows 7 format.exe utility (I think right-clicking the drive icon and selecting format would bring the same effect, just do as you prefer). After a complete format (into FAT32, by the way), as I tested, speed of file copying onto the drive has raised to 14~15MB/s, which is much better than 3~7MB/s I observed before the format. Read speed is high as always (100MB/s is quite common for large files). I actually did the format twice. The first time it took quite some time (more than half an hour) to complete (as I observed in Windows Performance Monitor, the Write Bytes/sec was for most parts 6~14MB/s, although for some parts it was up to 102MB/s). The second time it completes quite fast, within minutes (almost constantly above 100MB/s as seen in Perfmon). I believe a disk format is affecting the performance somehow.

1 Like

Hope this tip helps. If so then it would prevent the drives from becoming vain too quickly. :slight_smile:

A very impressive analysis Mr. r_mosaic Thank you.

Maybe you can try to erase with Parted Magic’s Erase app if the drive supports Secure Erase ATA command.  Secure Erase your Solid State Drive (SSD) with Parted Magic

Just out of curiosity how are you all testing the speed? Benchmarks, simple file transfer? What I noticed on my Extreme 3.0 is that if I copy a large number of small files the transfer speed is really slow. Below 20MB/s but if I copy a few large files (1GB+) the transfer speed is normal 100MB/s+. 

i just bought one usb3 sandisk extreme, at first the read & write speed were like 30 ~ 40 MB/s almost the same on both usb2 and usb3 ports, i thought it was strange i formatted the disk to NTFS quick format, but the speed didnt change,

i solved this problem by updating my motherboard drivers like intel chepset, intel rapid storage, bios others ,

after installing the drivers i restarted my pc, then the speed jumped to read speed around 150 ~ 250 MB/s

write speeds around 100 ~ 150 MB/s 

i was like whaaaat speed.

i think the problem most of the owners of this sandisk extreme usb3.0 is with drivers, formatting does virtually nothing.

i hope this helps.

I also have this problem, flash drive was super-fast when new, now… it depends. Completely unpredictable.

I’m using HD Tune Pro to write it all to zeros. First passage has variable speed, some points very fast (100+ MB/s), others very slow (~7 MB/s). Second passage, constantly over 100MB/s… Therefore the problem seems indeed to be the absence of TRIM support.

This makes this thing close to useless in terms of speed. Now I know I will never be able to trust it will be speedy when I need to put something into it really fast.

What a let down :frowning:

Therefore the problem seems indeed to be the absence of TRIM support.

Are you running Windows 7 or Windows 8?  And did you enable TRIM support on your pc?

http://www.buildcomputers.net/trim-support.html

I can get speeds of 135 MB/s when I copy FROM the flash drive to the SSD internal hard drive in my computer. HOWEVER, when I copy FROM the internal SSD drive in my computer TO the SanDisk Ultra USB 3.0 flash drive, I get the same slow speeds as with the older USB 2.0 flash drive and hard drives. This simply makes no sense whatsoever. The speeds both ways should be the same, since the SSD drive runs at 550 MB/s, and the SanDisk Ultra is slated to be a MINIMUM of 100 MB/s. And yes I have USB 3.0 on my motherboard. I have tried ALl USB 3.0 ports and this is the same issue. It is the same on my Windows 10 laptop. My desktop computer has Windows 8.1 ALL updated and current.

Mine reduced from From 80 MBpS to 800 KBpS, tried formatting twice but nothing helped. Any solutions?

Umm… I cant say much about the read speed but to solve the transfer speed problem I bought a 3.0 USB and the speed increased but not that much. After searching a lot I found a multi threaded file transferring software can make a huge difference in the transfer rate. I’m currently using GS Richcopy 360 which has 100% multi threaded file transfer which makes the process lightning fast. Although its paid but affordable and it saves your precious time, time is money according to me. You can also try it, hope it helps