SanDisk Ultra Dual USB Drive 3.0 corrupted and cannot repair with PC [Solved]

My problem seems to be completely unique, flash drive was working. I dumped my firmware from my PS3 to the usb, however afterwards when attempting to reconnect the usb to my pc, it now shows up with 0 volume, and either removable disk drive, or USB Drive. Cannot access it or reformat, attempted to use tools but they would crash whenever usb was plugged in before or after opening the tool, attempted to use chkdsk e:/r to fix it but froze upon start of the command. USB shows up in This PC and Device Manager, device manager claims it’s working properly, have reinstalled, disabled the drive, attempted to use Disk Management but froze when connected.
I only just received the product an hour ago and already it is unusable :sob:

I’ve been attempting to find any information on this issue however it seems that no one has ever come across this problem before :confused:

Edit: I had a spur of the moment thought, because it was dual usb I attempted to plug it in my phone, it recognized it was corrupt and fixed it, thank god this was dual usb because all attempts on PC was causing freezes on every attempt.

Happy to read your edit. :slightly_smiling_face:

Be sure when removing a USB drive from a Windows system to use the Windows Safe remove option. Otherwise things can go south.

I have a very similar problem. Suddenly, my files disappeared from the vault. The lock file had to be renamed to grant me access to the login screen, and then, after successfully backing up the documents dir, the backup of the desktop failed with the same error. I have tried the Repair Vault option, but killed it after it ran for 5 days.
I will keep looking on forums for a solution, but I think this thing is expensive trash.