Strange behavior on my USB

Hello. I have been using a SanDisk Ultra USB 3.0 256GB USB as extra storage for the better part of 3 years and it’s worked like a charm but the past week or so it has been acting rather strange. Initially it would let me access the files but then it would hit me with Cyclic Redundancy Error. My computer would boot up terribly slow with it plugged in. I tried to use chkdsk to attempt to clean any errors but it would hit me with the “cannot open volume for direct access” I would have moved the files to a recently cleared portion on my hard drive but the holidays got in the way and yesterday my computer straight up would not let me view any of the files with it plugged in. The slow boot up turned to frozen boot up. I tried to restart my computer last night and it wouldn’t do so with it plugged in. When it’s plugged in, Windows Explorer is unable to do anything if I click on the drive. I understand that one shouldn’t pull it out while it’s “in use” but I take it out and the computer does what I tell it to do. I’m confused at how a USB can make my computer act like that. The files weren’t too important so I’m not bothered if it’s a total loss.

1 Like

The drive is a SanDisk Ultra USB 3.0 256 GB KCC-REM-TAD-SDCZ48 BQ2202001185W SDCZ48-256G if that helps it. My drivers are all up to date and my other flash drives work okay

1 Like

Hi @ActilePep ,

Have you opened a Support Case? If not opened, for more information, please contact the SD Technical Support team for best assistance and troubleshooting:

1 Like

The first thing to do is check for CRC (Cyclic Redundancy Check) errors, as these indicate data corruption during read/write operations, mainly explaining the slow access and file errors. Try updating the drivers and run chkdsk to fix such issues.

1 Like

I tried to use chkdsk to attempt to clean any errors but it would hit me with the “cannot open volume for direct access” and all my drivers are all updated

1 Like

The “cannot open volume for direct access” error typically occurs when you try to run chkdsk on a drive that is currently in use or is mounted. To successfully run chkdsk, you should run when the drive is not actively in use. Also, try to run the chkdsk in Administrator mode only.

Hi and Hello:

I am new to the SanDisk Forum and guess what? I have the same problem.

I cannot gain access to the needed file in the vault. My desktop with “my PC” will show my C:\ volume with folders and files but the SanDisk Volume F: only shows the USB drive, disk “F” and NO capacity in use and/or the files that are associated with this drive.

I should have realized I was in trouble with many occurrences of CRC errors shown for the drive prior to my issue now which is “dead USB drive” with password on board (strong) and encrypted files.

Is there a backdoored access from San Disk?? i am afraid I am hosed.

Comments?? Recommendations??

2 suggestions:

  1. After booting, insert the USB drive, then run a chkdsk /f command for the drive.
  2. For important files, maintain a backup somewhere.