sanDisk Extreme USB 3.0 flash drive 64 GB is not accessible

Hello there,

I have a sanDisk Extreme USB 3.0 flash drive 64 GB (see the attached picture) and it worked for 3 years. Lately the drive is not any more accessible and suddenly I can’t access it when I plug it on windows or Linux. Unfortunately I have very critical important files (e.g. words, text and power points, etc.) on the USB flash drive and I want to recover them.

The observation of the problem is as follows:

1- First I plug the USB drive on the USB interface on Laptop.

2- No drive is appearing on my computer at first stage.

3- After some minutes (around 5 minutes), the drive appears on my computer but when I try to access (double-click) it, windows prompt error “Please insert a disk into removable disk”. I also noticed the USB drive shows 0 bytes when checking the properties.

4- In the device manager, I see that the “USB controller” showing the “USB Mass Storage Device” of this USB drive as recognized. While the “Disk drives” shows an entry but it is not recognizing the sanDisk driver.

I tried the following actions (as recommended by some sites) but it didn’t help:

1- Reinstall/Update the driver software.

2- Change the device drive letter.

3- I tried other laptop and other USB interface

I would like to ask if there any software or a hardware (e.g. access the flash chip through external wiring) solution to recover/access those important files.


I think you have done everything possible alifahmy.  If the drive is not accessible no software will access it else I would suggest running a CHKDSK on it.

You could try using some emory paper on it’s contacts and the jack’s contacts that you are plugging it into.  LIGHTLY.  This to remove any oxidation or smoke or dust that might have gotten on them.

Other than that I think the drive may be at EOL.