SanDisk SecureAccess V2.0 doesn't see my encyrpted Vault files, i am stuck!

Hi all!

i have been using SanDisk Cruzer Blade 64 GB with SecureAccess, it was really fine at first when using the program. That was working properly but when there were increased number of files(about 17 GB) in the flashdisk, the program started to working with freezing. It’s really annoying, this program has made my flashdisk like a supermassive black hole. I want my files back but i can’t reach them because they are all encrypted by SecureAccess. I had really important files in that stuff.

Firstly notice that, i didn’t forget my password, it’s a different issue.

I write the thing i did step by step:

1 - When the freezing has had gotten much to me, i have decided to copy those two SecureAccess program files(exe and vault files) to my desktop, to copying my files to my computer from there. (i had done this before and it was ok for that time)

2 - i didn’t know there would be something like this, but after i have copied those two files to my desktop, i have deleted the same files that are on my flasdisk(because they were on my desktop already now). The real issue has started by this point.

3 - After i have deleted SecureAccess.exe and Vault files from my flashdisk, i have returned to the ones that are copied on my desktop. And clicked SecureAccess.exe  aaaaaannd…ta-daaaaa!.. The program was resetted spontaneously and i was obliged to set a new password up. So i did that. But when i have entered the SecureAccess safe emblem like before, there were no decrypted files of mine!!! 

The Vault folder healthly was there as encrypted, but SanDisk SecureAccess couldn’t read the files in that.

So, all my files were like ‘‘deletedly’’ gone. Does SanDisk have got a solution for this victimization??

Your SecureAccess program is useless, if i had known that i would have run away from that.

As i am one of your customers, please help me now! 

I want a satisfying answer, not a robotic one. If there is no solution for this case with SecureAccess, then suggest me a good program to decrypt my files from DAT to their original condition. AND I WILL NEVER EVER USE THIS PROGRAM ONCE MORE, NO MORE!!

Thanks! :manfrustrated:

i am still waiting for an answer and there’s still nothing.

I’m really angry because this secureaccess thing has swallowed my very important files and folders like a black hole!!!

[  I didn’t know there would be something like this, but after i have copied those two files to my desktop, i have deleted the same files that are on my flasdisk(because they were on my desktop already now). The real issue has started by this point.  ]

[[  I want a satisfying answer, not a robotic one.  ]]

Pi pi… pr … pri… I am a robot… I do not discriminate… pri… pi pi…   pi…  pi pi pi pi…
SecureAccsess was designed to work only in UFD… pr… pri… prt… pi… pi…  pi  pi  pi  pi…

[[[  As I am one of your customers, please help me now!  ]]]

Well, since you insist… I’ll bring the human…

:smiley:  Hi Tjrr,

Dear member of SanDisk Community, welcome.

Please, do not grieve, friend:

Remember that, there are two softwares, one for Windows and one for Macs.
And SanDisk SecureAccess Software you must install in the UFD.
SanDisk SecureAccess software is supported by Windows XP, Windows Vista, Windows 7, Windows 8, and Mac OS 10.5 and up. Use with a Mac requires other software download.

The latest version (April 2014) of SanDiskSecureAccessV2, you can download (free) from here:  

1-     Downloads on the UFD, to SanDiskSecureAccessV2_win, (if you have PC).

Beware: If you figure thus: SanDiskSecureAccessV2_win.exe, go T_ools/Folder Options/tab/View/_ and tick: hide file extensions, by the way, you notice, that are also branded the choices: hide files protected, and: do not show hidden files and folders.

2-     Then, you install the program, password, etc. And you will have two files:
2.1-  SanDiskSecureAccessV2_ win , (the application).
2.2-   SanDiskSecureAccess Vault (which is the folder that contains the encrypted files).
2.3-   If you lose or delete to SanDiskSecureAccessV2_win (2.1), there is no problem, as other download, and ready.
2.4-   But if you lose or delete a SanDiskSecureAccess Vault (2.2), missed all content (maybe with Recuva can recover).
2.5-   If you can change the name, the application (2.1).
2.6-   Do not you can change the name, the folder/Vault (2.2), because the name is generated by the application (2.1), and if you change it, the application will not open, and will generate a new Vault.
2.7-   I f you can move on, too, to the application (2.1), a any folder.
2.8-   You can not move the folder/Vault (2.2). You should leave it in the root of the UFD, because that is where the going, “find” the application (2.1).

Beware 2: Always make, backup content, copy the Vault, clone the UFD, etc., and save everything in “safe place”.

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                            


If you want, a help from friends, “as befits”, then, you have to send a message, “as befits”, Understand?
_ If you want, _ you answer to “time and manner”, then, do not send an imperative and insolent message, _ understand? _

Please, inform yourself before using a program, and makes no mess, and do not blame others for their mistakes.

See this link, which hopefully will serve:

And if you think, go to the competition, read this link before:


(Robot Google, translated)

Hey Alfred , thanks for the detailed and ‘‘non-robotic’’ explaination for the first :smileyvery-happy:

After this, i have already read the informations about SecureAccess before, that is to say i know the working principles of the program. I’m aware of what could happen if i delete those files from the flashdisk.

Read this:

Before this incident has happened, moreover ago i had done the same thing, but just without deleting the same files on my flashdisk. I mean, this flashdish program also works on Windows 8.1 just by copying those two files from flashdisk to the desktop. Even with the same password on the flashdisk. I have experienced it by the way. The problem has started after when i have deleted those two files(SecureAccess program and its Vault) from my flashdisk, with thinking ‘‘i have already got them on my desktop, i may delete them now.’’

I have only deleted the ‘‘Vault’’ folder from my flashdisk after i have copied that to my desktop. So i have still the encrypted datas of my files, the problem is SecureAccess doesn’t see them no more, even if i have installed the program all over.

Yes, i have written above that i am angry because there were really important files even than this program. 

I ask for this: if SecureAccess couldn’t see and open them again; is there a good program you suggest me to get my files back in their real condition as before?

Thanks for your caring.

:smiley:   Hi Tjrr,

Ok! friend, the only program I know, to retrieve the contents of Vault, is SecureAccess.

Then, very carefully, please, do the following:

1 -  Copy in the UFD, the Vault you have on your desktop PC.
2-    This folder, must have the exact name [SanDiskSecureAccess Vault].
3** -**   Download, the latest version of SanDiskSecureAccessV2_win, in the UFD, and open.



Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                              (Google translated)



:smiley:   Hola Tjrr,


Ok! amigo, el único programa que conozco, para recuperar el contenido del Vault, es SecureAccess.

Entonces, con mucho cuidado, por favor, haremos lo siguiente:


1-  Copia a la UFD, el Vault que tienes en el escritorio de la PC.
2-  Esta carpeta, tiene que tener el nombre exacto: [SanDiskSecureAccess Vault].
3-  Descargas, la última versión, de SanDiskSecureAccessV2_win, en la UFD, y abrir.


Suerte, y luego nos cuentas, qué pasó, por favor.


Saludos, Alfred.

Hi, thanks for replying quickly.

I was away from the Internet for a few days. I will check it out and edit this message if that’s worked.

Best regards.

Edit after try: Nothing has changed, take a look at the picture of my screen;

:smiley:  Hi,


1-   I see, in the photo (congratulations), that in the UFD (F), that you have the application (SSAv2) and folder (SSA V), so good.
I see, also that could open the Vault, and no problem with the password.

2-   But, I see, that My Vault, contains the folder that you “want to extract”, and can not. Nor does can open?

3-   The strange thing, is that this folder, that is in My Vault, has the same name, that the encrypted folder, which is in the UFD, out of My Vault.
So I think, that what happens, is that “to extract” the folder (SanDiskSecureAccess Vault), that is inside My Vault , “collides” with the folder (SanDiskSecureAccess Vault) , out of My Vault, in  the UFD.

4- Then, try to change the name, of the folder (SanDiskSecureAccess Vault)  that you have in My Vault , and see what happens.

Regards, Alfred.                                                            (Google translated)

:smiley:   Hola,


1-   Veo, en la foto (felicitaciones), que en la UFD (F), usted tiene, la aplicación (SSAv2) y la carpeta (SSA V), todo bien.
Veo, además, que usted pudo abrir el Vault, y no hubo problema con la contraseña.

2-    Pero, veo que My Vault contiene, la carpeta que usted “quiere extraer”, y no puede. ¿Tampoco la puede abrir?

3-    Lo extraño, es que esa carpeta, que hay en My Vault, tiene el mismo nombre, que la carpeta encriptada, que está en la UFD, afuera de My Vault.
Entonces, creo, que lo que sucede, es que “al extraer”, la carpeta (SanDiskSecureAccess Vault) que está adentro de My Vault,“choca” con la carpeta (SanDiskSecureAccess Vault) que está afuera, en la UFD.

4- Luego, prueba, a cambiar el nombre , de la carpeta (SanDiskSecureAccess Vault), que usted tiene en My Vault, y vemos que pasa.

Saludos, Alfred.

Hi again! And thanks for quickly replying once more :smiley:

I can’t say that i have completely understood you. When i enter into that folder see the files then, take a look once more;

They are all still encrypted :cry:

Edit: i have done the way that you have spotted; changed the name, now the program has started to freeze when i try to enter the changed-name vault folder. 

Edit 2: I have just entered now and no, still all the same, just as in the picture above; all is encrypted.

1 Like

:smiley:  Hi (Merhaba),

I see what happened: the folder that is in My Vault, does not have to be there, ever. That is the error.

1-  The folder that is in My Vault, is the original folder, which contains the encrypted files.
2-   This folder, you must be out of My Vault.
3-   On the UFD, generate a “New folder”.

4-      Extract from My Vault, the folder containing (SanDiskSecureAccess Vault), in the “new folder”.

4.1-   Click / Right in the folder, which is inside of My Vault.
4.2-   In the menu, click the left button in to “save file to”.
4.3-   In the new menu, choose _"_New folder" and then button to save.

5-   If this, was done good, later we see…

Regards, Alfred.                                                        (Google translated)

:smiley:   Hola,

Ya entiendo lo que pasó: la carpeta que está en My Vault, no tiene que estar ahí, nunca. Ese fue el error.

1-  La carpeta que está en My Vault, es la carpeta original, que contiene los archivos encriptados.
2-   Esta carpeta, tiene que estar afuera de My Vault.
3-  En la UFD, generar una “Nueva carpeta”.

4-       Extraer de My Vault, la carpeta que contiene (SanDiskSecureAccess Vault) en la “carpeta nueva”.
4.1-   Click / botón derecho en la carpeta, _ que está adentro de My Vault. _
4.2-  En el menú, click con el botón izquierdo, en “guardar en”.
4.3-   En el nuevo menú, elegir la “Nueva carpeta” y luego botón guardar.

5-   Si ésto, se realizó bien, después vemos…

Saludos, Alfred.

1 Like

Hola! :smiley:

Just asking for being sure; do i have to copy that My Vault folder from the program to flashdisk with creating a new folder; where there already SecureAccess.exe and Vault folder exist?

And i am sorry for the entire messages, when i was in anger. But i have my really important folders and photos in that program. 

Have a nice day!

:smiley:   Merhaba,

Yes, please, make it, you understood well.

Inside, the “New Folder”, put the contents of My Vault (SanDisk SecureAccess Vault , (original)).

Then the UFD, thus:
1-   SanDisk SecureAccess Vault
2-    SanDiskSecureAccessV2_win
3-   New folder (containing SanDiskSecureAccess Vault, (original))

Then, you say to me.

Regards, Alfred.                                                                                        (Google translated)

:smiley:   Hola,

Si, por favor, hacerlo, usted entendió bien.
Adentro, de “Nueva carpeta”, poner el contenido de My Vault (SanDiskSecureAccess Vault, (original)).

Luego, la UFD, quedará así:
1-   SanDiskSecureAccess Vault
2-   SanDiskSecureAccessV2_win
3-   Nueva carpeta (que contiene SanDiskSecureAccess Vault, (original))

Luego, me dices.

Saludos, Alfred.

Hey Alfred,

i have tried to do the way like you said but the freezing has started once more.

In addition, i have created a new folder as you spotted and i have tried to copy the My Vault folder with draging into that and the program has started to freezing. I could do it with entering to My Vault and selecting all the files then copy to the flashdisk but the program doesn’t let me to do it, you know.

I guess we are stucked now :cry:

:smiley:   HI,

Sorry, but try it the other way around, see if freezes well.

Add to My Vault, any file, or photo.
See if you accept it, and then, out of the Vault.

Regards, Alfred.

Isn’t there an other way? Those encrypted files have no other copy anywhere, so i need them to be decrypted. I’m really serious, those files are truly important for me.

This program is useless and bad, why does SanDisk still keep adverting the program? It also freezes in normal times, not only for this case.

I’m waiting for a cure or a program from SanDisk which could decrypt those files.


i have the same problem with _SanDisk SecureAccess Vault_ when i opened SanDisk SecureAccess Vault it isn’t ask for a password it’s just files encrypted  by SecureAccess  . i’m really  disappointed. i shouldn’t  deleted  my original photos and files in the first place. :womansad: