Sandisk SecureAccess Vault 3.02 Lost All My Files!

I have been using this flash drive for at least 3 years. It is in perfect shape but it hid all my files for some reason all of a sudden. I cannot see any of them. But I can see that 102 GB of the disk is still full so the files are not deleted, they must still be somewhere in the vault. Please help me access my files through the vault!!! I use Windows.

Thank you

Well, here’s hoping the solution is to simply run a CHKDSK command for the drive. If that doesn’t work you will have to use your backups of them.

Okay, so I did the command. It gave me a bunch of information but nothing changed. How do I use the backups?

After you ran the CHKDSK command did you Safely Remove the drive and reboot before retrying the drive?

Have you tried the drive in another computer?

Are you able to sign in to the drive’s SecureAccess system?

I have the same problem, I have already tried everything, you can solve?

Exactly the same issue. After plugging the usb drive only non-encrypted files appear while the Sandisk SecureAccess application and vault 3.02 have dissappeared. Drive space indicates that the files must be around there but not visible. Only a few strange files appeared![Capture|690x154](upload://4qYvlZ6MnmDMFJ6A1jLm1tZwiDQ.png)
Did run chkdsk command but nothing helped. Any help?