SanDisk not working help!

I’ve always used SanDisk Extreme Portable SSD prior to this and suddenly this morning the SSD doesn’t show up on my laptop. I’ve only used the SSD for 2 months and I’ve always left my external SSD connected to my laptop. There are no signs of anything wrong the previous days that I’ve used it and also no damage done externally.

When I plugged the SSD in, it will show up in the device manager. I tried the advice to uninstall it and restart and it didn’t work. When I open disk management, the SSD will show up but it says ‘no media’ and there’s no partition at all. Can anyone help? I can’t believe it’s dead cause I’ve only used it for 2 months.


Hi. I have EXACTLY the same problem, although I’ve had mine for about 12 months. Suddenly this week, Wednesday in fact, it’s not showing up on my pc. It’s there in the device manager, but as you say “no media”.

The same. 6 month use.

Same thing here. It just suddenly stopped. Tried rebooting, changing ports etc. When I plug it in it is seen by device manager. When first plugged in, it shows up in Devices and Printers with an exclamation point which disappears when the drive briefly shows up on the sidebar for less than a second then disappears again although it remains visible in Devices and Printers. Disk Managment shows it as removable but states “No Media”

This drive has been rock solid till now. I was trying to update a file on the drive when it failed. Upon reboot it was no longer showing up
Checking the event log for the drive shows:

12/16/2021 7:03:24 PM Device install requested
Device SWD\WPDBUSENUM_??_SCSI#Disk&Ven_SanDisk&Prod_Extreme_55AE#7&35b2c743&0&000000#{53f56307-b6bf-11d0-94f2-00a0c91efb8b} requires further installation.

12/16/2021 7:03:24 PM Device not migrated
Device SWD\WPDBUSENUM_??_SCSI#Disk&Ven_SanDisk&Prod_Extreme_55AE#7&35b2c743&0&000000#{53f56307-b6bf-11d0-94f2-00a0c91efb8b} was not migrated due to partial or ambiguous match.

Last Device Instance Id: SWD\WPDBUSENUM{f5b7a714-3e2f-11ea-ad07-9cb6d064b17c}#0000000000100000
Class Guid: {eec5ad98-8080-425f-922a-dabf3de3f69a}
Location Path:
Migration Rank: 0xF000FFFF0000F102
Present: false
Status: 0xC0000719

12/16/2021 7:03:24 PM Driver service added (WDUDFWpdFs)
Driver Management has concluded the process to add Service WUDFWpdFs for Device Instance ID SWD\WPDBUSENUM_??_SCSI#DISK&VEN_SANDISK&PROD_EXTREME_55AE#7&35B2C743&0&000000#{53F56307-B6BF-11D0-94F2-00A0C91EFB8B} with the following status: 0.

SAME experience…worked fine for 6 months then nothing, tried different usb, different computers, message says to insert media in the USB drive. CSR will replace but that does nothing for DATA. Recovering slowly now, shows lost partitions, unsourced files, SSD is a misnomer in this case. Very disappointed, lost tons of work data & will never buy another.

If you lose data, install a data recovery program like SanDisk Extreme SSD Failure: Tips to Prevent from Further Damage to recover files from your SanDisk Extreme device.