Sandisk Extreme USB drive 32GB - SecureAccessV3win has hung and Cannot close

I was in the process of copying over some more files and the disk full message appeared " Cannot continue message" tried to go back into the vault to delete some data and all hung.

Tried to find a way of closing the process but could not find it in task manager. So I removed the drive and  plugged it into a second laptop and its the same just says that SecureAcess is running.

Can anyone help me get this sorted and close the app on the drive

There is a Secure Access file somewhere on the drive, who’s name I don’t recall either, that needs to be deleted to unlock the app.

Sorry I don’t remember more but it is an answer that I’ve read on here before.

Thanks for the tip Ed it worked a treat

I found something called lock in settings. it makes a new file each time I try and access the drive





lock.rmlock.rmlock… and so on

So as you suggested I have deleted them and now we are good to go so thankyou very much


Hi Ed,

seems I spoke to soon. maybe I should not have deleted the “lock” file as I got logged in and now got the error:

“Invalid parent path in the archive”

Are the deleted files in your Recycle Bin?

What I do before I delete a file I rename it, put an X at the end or in front then test the problem.

You may be at a point where deleting all the Secure Access files and folders and reinstalling it may be your best/only option.

Thanks for the reply yes I have carried out all those things and copied the directories into a new folder on my desktop however, still no joy but I seem to be missing the “lock” and “rmlock” files so maybe that is the cause of the problem they were there alright but somehow I must have accidently deleted them. I have not emptied my recycle bin but even so they do not seem to be there. May be a red herring but I recall them being there.

I seem to be able to log in but am now getting the error message “invalid parent path in archive”