More problems

This is getting discouraging. I posted about my initial problem (Can’t read vault files). Unable to clear that up, I copied most of the files I had originally put in the vault and couldn’t open to a holding folder. I then unsinstalled the Secure Access completely and rebooted my machine. I then re-installed Secure Access and added the files from the holding folder to the Vault, closed it and reopened. Now I can’t get them out!

 

I tried dragging to the desktop; that didn’t work. (I should note, that when I first tried to add them by dragging and dropping, that didn’t work, either.) I tried copying to the desktop; none will show up.

 

There must be something wrong with the software. What should I do?

I took everything off the drive and formatted it, uninstalled teh software from my computer, rebooted.

I put teh Secure Access exe back on the drive and ran it. It generated the Vaults folder and a file called something like cerem, adn opened the set-up dialogue for the vault name (which doesn’t rename the Vault folder, I learned early on; it creates a subfolder wiht the name you enter, so I don’t do that) and the password and EULA checkbox. After that, I added files and found that drag and drop worked. Everything seemed to be fine. I closed the vault and drive, logged out of Windows, logged back on, and now the Secure access does not appear allowing me to open the vault.

Really, I work in IT and I have never had so much difficulty with such device.

I also note, that whatever software created a brand drive icon has now also gone, so I only get a generic drive icon; a shame…

Can anyone straighten this out, or must I go back through the vendor and start fresh?

Thank you.

For anyone who may have read this far, I have discovered the principal problem, which is that I had placed the exe file in a folder on the drive, assuming that, like any other exe file I have ever used in 15 years, once run it could be placed in a folder somewhere. not this one. One I placed it back on the drive root, the cacert.pem file also reappeared adn things are finally working. (All except the SanDisk drive logo in My Computer…)

 

In any event, I, for one, would be grateful to see better documentation on this from SanDisk. I’m no fan of 237-page “Introduction to…” Device or Application X (unless it’s Photoshop or something), but surely the problems I have encountered are not all entirely unusual.

 

 

hmmmmm  When you buy the Extreme USB3 drive SecureAccess is in the root of the drive.  Movement of the exe is not required.

When you delete the SecureAccess exe from the the drive, download a fresh cop, the instructions say to copy it to the root for the drive and run it.

So you want the documentation expanded to say copy the download to the flash drive’s root, do not rename it, do not put it in a folder, do not change it’s attributes, just execute the file?

assuming

If you’ve been in IT for 15 yrs you know very well what “assume” means.

I accept your kindly chiding. I wrote in some haste from frustration and failed again to explain each detail.

I did not get to the download on the site, because I simply removed the exe file from the drive and placed it on my desktop while I formatted the drive. I then moved it back again. As far as assuming  (the familiar adage aside), this simply has been the first time I have encountered an exe file that needed to stay put in this way. By that I mean, that I have downloaded many applications – to the Downloads folder, desktop, or other folder – and never had to keep the file in that folder, either to run it or to store it after running. From your comment, I assume that I have evidently missed many that have the same requirement as this one.

As for the documentation in general, I am one who does not like instructions for everything to read like instructions on a box of brownie mix: Do step 1, Do step 2… There is, of course, a judgement to be made as to what and how much to include, and perhaps there are more details somewhere else on the SD site. In my view, in this case, when there is no indication that functionality will be impaired by moving the exe file, a cautionary note would hardly be too much. Having come across this after being told to check a non-existent check box, and then finding that renaming the vault folder does not rename it but creates an unwanted subfolder instead, I think it fair to raise the question of how much thought was put into the documentation/instructions. I have sent a polite letter to SanDisk in hopes that it may catch the attention of someone there. In the meantime, curiosity leads me to see if reinstalling the driver from the site will fix the icon logo.

Cordially,

Ulodesk

The icon comes from a file on the drive and is pointed to by the drive’s autorun.inf.

[autorun] action=Get special offers from SanDisk partners open=RunClubSanDisk.exe icon=RunClubSandisk.exe

However since you don’t need RunClubSanDisk.exe, and probably didn’t back it up :wink:, I would change the autorun.inf’s code to point to SecureAccess.exe.

As for documentation, nobody reads it.  Especially us geeks.  :smileyvery-happy:  However, the SecureAcess.exe does produce a warning window when it’s not run from the USB drive, adding a warning window when it’s not run from the root of the USB drive could be added.  (Maybe when someone else encounters the same problem you did. :wink: )

I’m glad you figured out the problem.