CRUZER - Secure Access - Waste of TIme

I am going to keep the pkg of 4 flash drives that I got at Costco yesterday.   Only because I can’t get back to Costco tonight.  What crap!  Twice I went thru the process of installing the Secure Access software.  Here’s how it all works for me:  I can access my secure files by double clicking the SA manager icon (out of sight on the bar at the right bottom near my clock in Win7)  and entering my password–pretty cool.   OR,  I can just go to “Computer”, “SanDisk” ( Devices With Removable Storage) then open SanDisk there and view all my files WITHOUT BEING ASKED TO ENTER A PASSWORD.  It’s like my files are in 2 separate locations…one is passworded and the othr is not.

So being frustrated I elected to try a live chat with a SanDisk rep.   That was an experience!  Not an unusual experience in this day and age however.  Somewhere in a foreign country this person was absolutely no help.  I’m not sure that he even understood what he was telling me.  He did the usual of trying to send me off to a website to follow instructions and call back if I still had a problem.   NOT.  I got him to hang around while I tried his quick fix which didn’t work.  So he gave me another website and told me to reinstall Secure Access Manager from there.  Of course that didn’t work and I was prompted to download it from a flash drive…which GUESS WHAT?   The tech had twice had me reformat so there are no files on it.  So I went to one of the other 4 drives and did just that.  SAME PROBLEM  as originally. 

When you first install the drive you are advised that there is an update available.  Install it and you’d expect that the instructions for proceeding would be accurate as far as the prompts, how they appear, selections to make and specific, accurate wording of which options to choose.   Well don’t expect any of that! 

So either I am the dummy here in which case I will sit back and laugh about this.  Regardless, this product may be a good one but I am not at all impressed with how it has worked for me so far and I am less impressed with the customer “no service” which has been provided.  

Soooooooooo, thanks for letting me vent and I will check back in here and see if someone who is smarter and much more patient than me can explain to me just how I should have made this all work in the first place.

Maybe I’ll be a little calmer in the morning and will be persuaded to skip the trip back to Costco.

Are you storing your files in the secure folder or outside the secure folder?  The latter would explain what you’re experiencing.

Each time I moved a folder from my desktop to the safe.  Still I figured that no matter where I put the folder be it the safe, the displayed page after opening the safe or anywhere in the “Vault”  ==any of those places would be password protected.  Just where is the other place you are referring to?

when you install secure access you should see the app runsecureaccess.exe and a my vaults folder. anything stored in the application will be encrypted and should not be visable unless you are looking in the secure access app. if you go into the my vaults folder you can see database files but these are encrypted and cannot be opened. below is the user manual for secure access hopefully that helps.

http://mp3support.sandisk.com/downloads/um/secureaccess-userguide.pdf

I have uninstalled all the SanDisk programs but will try again.  Specifically, what I seem to have a problem with is:

It appears that there are TWO different ways to get to the files which I put in the Vault.  One way is to open the Secure Manager, enter the password and view.  The other is to go to COmputer, Removable Disk, and open, in my case, G drive which is the SanDisk drive.  Here all the supposedly hidden files in the Vault are also in view and can be opened normally without my ever being asked for a password as in Secure Manager. 

So, anyone who has my flash drive can go to COmputer, Removable, etc and view all the files.  ]

It has been this was from the beginning. 

Again, what am I missing here?

the files will not be visable on the flash drive unless you copied them there. putting a file in secure access i.e. draging the file to the safe icon or draging the file directly into the secure access window will encrypt the files and you will not see them on the drive itself. 

By jove, I think I’ve got it!  It still seems confusing but after running thru the process several times, wifth your help, I’ve figured it out.  Thanks!  Now another question:

SanDisk chat tech had me reformat one of my 4 new drives.  He then sent me to a link: 

“Once you format the drive then please follow this link to download and reinstall the Secure Access on the drivehttp://kb.sandisk.com/app/answers/detail/a_id/2399/kw/secure%20access
Scott Nath: If you still unable to download and install the secure access then please get back to us”

When I went to the link I twice got an error message and was told to obtain Secure Manager from an actual flash drive.  This seems to render the original flash drive useless from a security standpoint.  Now that I understand how the system is supposed to work, I know what to expect when I use the remaining 3 (not reformatted) drives.  I do not get the same results using the one that has been reformatted.

No amount of trying will get it to work on my computer with Secure Manager.  Secure Manager does not seem to recognize the drive.  SEcure Manager works with the other drives which have not been reformatted.  So, in effect, thanks to SanDisk, my purchase of 4 secure-capable drives has resulted in 3 such drives.

Maybe you can help me fix this issue?  Or do I return the package to Costco and get a new package with 4 good drives.

Thanks again!

Re:  my last post…I guess my big question is:  How do I get necessary Secure Manager data BACK onto the original flash drive (as if it had never been reformatted) so that it will work like the other 3 and as it did in the first place?  Or is that impossible?

you can use the link you have or the secure access link stickied at the top of this page. you will download a zip file. copy that zip file to the drive and unzip it from there. if the secure access zip file is on your computer when you unzip it it will not work. 

copy the zip to the drive

unzip runsecureaccess.exe

delete runsecureaccess.zip from the drive

double click runsecureaccess.exe to run the program 

I finally went to another of the 4 drives; copied to my Desktop the RunSanDiskSecureAccess-Win.exe.  This is the file support referred me to as well as the “sticky” you mentioned above.  I was confused that it was not a .zip file however I then copied it to the drive that doesn’t work.  THen I opened the file on the drive and went thru the password assignment process.  Secure Access now works but I still have these questions:

1.  I’m not sure what, if anything,  I should now delete from the drive (as you suggested).

2.  To open Secure Access I must EITHER click on it on the Start Menu OR go into the drive and double click on the .exe file that I mentioned.  Is this the way it should be?

As New York’s premiere and URL=[http://www.newyorkasianescorts.com/]new york escort[/URL] leading escort agencies, we can make certain that only in New York can you find quintessential adult females with skills in pure, indulging pleasure. And it is entirely your URL=[http://www.newyorkasianescorts.com/]new york escorts[/URL] choice who to pick among our exquisite women from Cherry Blossom Girls, New York Classic, New York Colorful Escort, New York Fantastic, New York Juicy Escort, New York URL=[http://www.newyorkasianescorts.com/]new york asian escort[/URL] Magic Escort, New York Peach, Sweet Heart Asian Escort.
Our exclusive female escorts in New URL=[http://www.newyorkasianescorts.com/]new york asian escorts[/URL] York are not just bodacious and beautiful. They are amiable, liberated, tactful, conversational, courteous, prompt and mannered. You will find that any of our ladies is a great company to your business events, vacations or an escort to any of your itinerary. You should try our service, and we guarantee you, you will not be disappointed. We do it the New York outcalls way: just browse this website and see our lovely ladies, then call us up now and ask about her.

OK, I notice no one has said anything on this thread for several months, but I’m hoping someone will pick it up again. I am also having some problems making Secure Access work. It doesn’t download as a .zip file as was noted, but I was able to move the .exe file to my USB and install it that way. I moved everything into the vault - I figured out the issue about not having it also as unprotected files on my own, which took quite a while. However, when I then reconnected my USB drive nothing happened. I manually opened the drive and again clicked on the .exe file, but it was having me start over by creating a new password. I didn’t get that, which is when I searched for help and found this thread. I hadn’t seen the Manager program before that but then found it; however, when I clicked it, nothing happened. Frustrated, I then decided to start clean, so I formatted the drive and then re-downloaded and executed Secure Access, but continue to have the same problems. Nothing happens when I click the Manager icon on my desktop. Also, it says one way I can add files is to move them on top of the safe icon, but there is nothing like that on my desktop either.

I really want this to work, as I use the drive for confidential client files and need some kind of password protection. I’m not gonna be happy if I have to go buy a whole new flash drive. Any help here would be very appreciated!

I could be wrong but I think the .exe file you downloaded is to INSTALL Secure Access, not Secure Access itself.

I think you are right, but there is nothing else appearing on my drive other than the Vault file, which is all encrypted.

Total agreement:

Im an" old" Sandisk user… When windows 7 transition came, the “old” Sandisk encryption routine for XP  became obsolete…

This caused some minor conflict, but I finally purchased a new 8 gig Sandisk flash drive compatable with Windows 7…only to find the very same issues you mention…what crap.////

If you get it to open at all, after going through setup, ( and when mine did, it showed no vault icons) any file in the vault opens as a read only file… which has to be moved out of the vault to be worked on (Word or Excel) (OK to that) but then it has to be saved in a non-secure location and then dragged back into the vault… what crap…

Possibly leaving a “copy” unsecured, in a temp file somewhere, (at worst) or at best having to do file gymnastics NEVER necessary with previous versions…

What in the world is so difficult about simply opening and saving back to the encrypted environment period. and why open as a “read only file” in the first place??? Not secure enough???  It’s my vault !! Makes NO sense…

Im so disappointed with this product that I think I will regulate it to being a simple flash drive, and eliminate the unused encryption files and add on files… I would return it in a heartbeat if it were possible…I will not buy another Sandisk drive…