Sandisk Cruzer Blade 32gb with Secure Access. Broke!

Hi all,

First post, great site but sadly my lack of tech knowledge has meant i’ve not been able to find the anwser i require from searching your site.

Bought the above Sandisk Flash Drive last week. Transferred some photos with no issue at all, great. I then decided to utilise the Secure Access feature to protect files i would carry back and forth to work. I set this up with no issue’s, created password and dropped the files in required.

This issue began after this, i tried to remove the flash drive but my laptop advised the drive was still in use so i ran the task manager processes and it wasn’t. I had no choice but to remove the drive with properly ejecting. Now when i insert the flash drive i can’t access it. Windows 7 advises to scan and fix issues but when i do it tells me the disk can’t be scanned as it can’t access the disk. When i look the dik up under My Computer it shows the flash drive as being there but when i try to access it it tells me its empty and won’t allow me to transfer other files to it.

I’ve tried changing the drive letter (E to R) after some googling but this hasn’t resolved the issue. I’ve tried to format the drive but it won’t even allow me to do this action.

The files i transferred are still on my laptop so i have no issue with formatting the drive.

Any suggestions are most welcome.

I’m running Windows 7 64bit on a Sony Vaio VPCEH laptop if this helps.



Removing the drive while the system said it was in use screwed up the FAT.    Things that could have kept the drive in use vary from Windows Explorer, the machine’s AV, Windows indexing, to Secure Access itself.  Years ago my Zone Alarm FW use to tie up my USB drives as in use. 

The only way to guarantee a safe removal  in such a situation is to reboot the system.

Now as to your problem, I don’t know the solution.  If you find an answer or create one please let us know.

BTW Thanks for the detailed posting.