Cruzer Glide 64GB Windows cannnot access the specified device, path, or file....

I just bought this flash drive and have yet to get it to work. I am using Windows 8.  I deleted the SanDiskSecureAccess V2 and files and downloaded V3.  When I go to click on the .exe file I get the error message below.  I can read the .pdf’s off the drive, I tried uninstalling all of the USB drives from Device Manager, I’ve tried changing drive letter from D to I, I’ve tried updating the regedit file by removing all of the VDI_0781 references still nothing. I can take the drive to another computer and I don’t have this problem. I do have admin rights on my the laptop I’m trying to install it on and I have disable anti-virus software.  I not sure what else to try. I had the same problem at first with V2 but it was fixed by unistalling USB port via Device Manager. I don’t know what else to try…thinking about just taking flash drive back to Best Buy for refund.  Any suggestions appreciated.


Well for starters I’m pretty sure the file must be run from the USB drive not the C: drive. 

Hi Ed,

Thanks for the reply – I just realized I added the wrong screen shot :flushed:  I couldn’t even copy the .exe file from the c: to d: - got the same error. I changed it from d: to q: So, I downloaded and copied the .exe file from my 2nd laptop on to the flash drive successfully then inserted the flash drive on the other computer and tried to run the .exe file 

OMG never mind I just restarted my machine again and it’s working!!!

Should have known it was too good to be true – copied a couple of files – it locked up my computer so I had to reboot. After reboot back to same error. I give up!