Sandisk Cruzer Micro 8G Bricked?


Let me first state, there isn’t any important data on my device, it just doesn’t function at all.

If anyone would be kind to help me with the following issue(s):

My stick has become unresponsive after trying to “write” an img. file to it, using rufus I believe. To create a bootable USB drive. After a succesfull attempt I can’t access the drive at all, have tried various different running systems with known working usb ports. Tried on windows (7, XP) as well as Mac.

When I plug the device in, my windows machine (7) acknowledges a new usb device plugged in (sound) but doesn’t do much more then that, except it very briefly show a cd drive or sometimes a regular drive in “My computer”. It immediately dissappears.  On one (rare) occasion I got the following notification:


This tells me at least something is still alive, but very much corrupted or something… I think the filesystem has an error. I don’t know much more to say about it. The light does come on, sometimes stays on. In disk management it will also briefly show. Obviously it won’t boot what I intended to achieve. I have opened it, circuit seemed to be in good shape, no signs of hardware failure.

Ask me anything you need to know what I might have forgotten. Help would be appreciated. 

What did Rufus say when you asked them what the problem could be?

Haven’t got in contact with them. Good point, will try that. Otherwise, I would very much appreciate someone’s help or pointers from these forums.

Little update since my post; I have gotten some luck with approaching the device. There is this sandisk u3 software that I tried, but it crashes everytime, but when it crashes the device was then visible (as cdrom and drive) and would show up in diskpart aswell, where I could only assign the drive letter to it, no partition creating or formatting but at least something. It would also show up in devices and printers. At least, it would appear for as long I kept the crashed sandisk program open.

Interesting.  The U3 app was discontinued about 10 yrs ago at this point.

So when “it” shows up in diskpart and devices and printers what is “it”?  The CD drive or the USB drive?  And when the U3 app crashes what does it crash with?  What’s the error msg?

Hey Ed,

"It’ shows up as the cruzer itself:


But when I click on it’s propeties it shows this:


Any software I should try out to get this device to format?

hmmm  Does your machine have a CD-ROM drive?

At this point I would try something like a GParted system to repartition the drive then format the partition.

you can try using the diskpart clean command. that should clear all partitions from the drive. If that completes you can create a new partition and format the drive. 

My laptop does have a cd/dvd/rw drive, that, as a matter of fact has been acting strange lately. I have actually replaced the drive cause I thought the lens was worn out, but that is not that case since the replacement drive has the same issue not reading any disks. So, this could be related, I don’t know… I tried a clean instal of windows 7 btw, did not resolve the issue.