Retrieve data from Sandisk Cruzer

I have a 4GB Sandisk Cruzer.  It worked well for over a year.  Then, all of a sudden, I can’t access the files on it.

Sometimes, when I plug it in, it says something like “drive not formatted. would you like to format it now?”  I always say No because I don’t want to flush the whole drive.

Sometimes, it plugs in fine (using Windows PC’s).  I can see the whole file structure in Explorer.  However, once I try to access the data, the light on the drive starts to blink quickly (about 5 times a second - on and off) and nothing happens.

I believe the data is still there.  How can I get it off.

Many thanks in advance.

I have used my sandisk cruzer 8GB for a little over a year and all of a sudden it won’t work.  When I plug it into a computer it doesn’t recognize the drive at all.  I have tried multiple computers to rule out the possibility of the port being damaged.  I store a lot of my information that I need on a daily/weekly basis on this disk and desperately need to retrieve the information.  Does anyone have any suggestions or know if the data could still be recovered?