Sandisk Cruzer 64gb will not read in my work pc, but works in all other computers.

The hardware profile for the flash drive in device manager shows up under disk drives as a sandisk cruzer usb device, It will attach it to G:\ but will be blank - unreadable or sometimes it doesn’t show up at all. When it does show up It has a size of 0 with 0 bytes available. Sometimes if I reboot my pc it will show up until I eject it. I can plug it into any other pc and it works fine. I can reboot the pc and boot linux or any of the recovery tools from it as well on the subject pc and it works fine.

Any other flash drive I plug into this pc works even other sandisk flash drives. I tried a 32 and a 16gb that I have and both read fine on this computer. Any suggestions on how I can get this usb drive to read correctly on this computer? All are usb 2.0 devices. I have tried the 64gb device every usb port and reacts the same way on all.

Forgot to mention that PC is Windows XP Pro.

Update: I thought maybe a bad registry entry could be messing with the device, and started looking through the registry for sandisk entries. I found this entry “HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\DeviceClasses{53f56307-b6bf-11d0-94f2-00a0c91efb8b}##?#USBSTOR#Disk&Ven_SanDisk&Prod_Cruzer&Rev_1.26#20052845011437C02C8E&0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}” that tied to my device, and deleted it. Then plugged the flash drive into the pc. It loaded correctly for the first time in weeks. I have been dealing with not being able to use this flash drive not troubleshooting all that time. So I ejected it and looked at the registry again, the entry was recreated, so I plugged the flash drive in and it would not load. I tried deleting the entry three more times and only once more did it load properly. Each and every time the entry was recreated but the device did not load properly as it did with the first 2 times I deleted the registry key.  I don’t guess this really was part of the issue, but wanted to share what I did in case it does tell you somthing more than it told me. If there is a list of registry entries that I could remove that may tie to the problem besides that one please let me know.

Dude Sandisk blows All my other flash drives work with no problems Sandisk 32 gig and my 64 gig will show 0 on boh my xp pro machines and they have 16 and and 38 gigs on them WTF? and trying to get Sandisk support is almost impossible. If you find out why they show 0 when you insert it in your work machine please let me know. I,m thinking maybe its the way the format was done in exFAT since anything over 4 gigs needs to be formated in ex Fat or NTSF or it wont let you fill past 6 gigs , Yeah they say 4 gigs but i was able to dump 6 gigs in regular FAT format. So my bet is the EX FAT format problem… Try it and let me know…

All my other flash drives work with no problems

How many of your other flash drives did you reformat as exFAT?  

So my bet is the EX FAT format problem.”

My bet is on you reformating the drives.  Windows XP doesn’t support exFAT unless you install update KB955704.  Did you?

The SanDisk drives would have worked just fine if you hadn’t reformated them before trying them.


Are you running Kies on your pc?  And are you using the Windows Safely Remove function when ejecting the drive?

Also this post might interest you.

The quickest explanation to this is either the USB port is disabled at the work PC or the limited user rights prevents the usb from running.

No, usb is not disabled. I have other flash drives that work fine. Even sandisk ones. It’s this one flash drive on this one pc. Also I am admin on this pc. The usb installs and sometimes it will show properly as well.

No, I do not run Kies. 

If it helps I am running on a Dell Optiplex 760 with windows xp pro x86 with 3gb of ram.

I do safely eject the usb. it has always recognised the device as being connected, but the drive may not show up and when it does it may or may not show properly. I have had some success with going to the ubstor registry entries and removing the sandisk registry key then plugging the flash drive back in. Most of the time since my first post that works on making it show properly. Any ideas on a permanent fix?