Reinstall required with every use nearly


Having an issue with a Sandisk Cruzer 64GB (SDCZ36-064G).  Bought it a good few months ago, issues were present immediately.  I work on an IT helpdesk so use this stick in a lot of different systems. 

What’s happening is the drive is failing to be recognised by Explorer after the second or 3rd use.  1st use in a PC works fine every time, but after that is gets progressively worse.  The drive will flash on and off (usually, when idle, it “pulses”) slowly at first, then after a minute or so it starts to flash rapid, explorer won’t see it at all, but it will show up in device manager (invisible to Disk Management too)

Uninstalling the driver via device manager, unplugging device then sticking it back in seems to be the fix (9 times out of 10) and I’ve even tried locating the .sys files that the driver installs with and forcing windows to re-download them (cut them from the “Drivers” folder then reinstall device)

I always use the safely remove option, and have tried formatting the drive previously (formatted to NTFS ATM) and every other drive works in my system fine.  This happened in my old Windows 7 ent x86 and new Win 7 ent x64 machine, also happen in Win7 pro and I think I remember it happening in an XP machine too, tried using both front ports and rear ports (in case of a power issue)

Finally, I run linux at home, and with my home machine I have never experienced a single issue with this drive, which leads me to believe the drive itself is fine.

Any ideas? :smiley:

Stickly WAGs:  antivirus app, antimalware app, work’s security policy, low voltage.

Also, try to use it in safe mode to isolate the issue. And see if you are still getting that pop up message.


Used various antivirus since I got the stick and issue had been present throughout, for a time used the same AV as the one I use on my girlfiends and this works fine in hers, and I co- manage the works policies so know it’s nothing to do with that.  Also other sticks work fine.  My second stick of a different brand has essentially the same data on it too and that works fine.  As for the voltage, I tried it in front and back ports and same thing.  Also did the same on my old PC which was a different brand and format (old was a mini tower, my current’s full tower) with same results.


Just tried the stick on my girlfriends PC which is still Windows cause I was gonna try safe mode, and strangely enough the stick works fine. Her’s is essentially the same as my old work PC too (I think 1 model out).  Not sure what pop-up message you’re referring to though.  I will try safe mode on my work’s on Moday, also will try other PC’s to try isolate OS version and give me any further clues.

It’s almost as though the drive isn’t properly registered as disconnected when I take it out (I always use “safely remove”) and so when I put it back it confuses the OS.  Also, re-read and realised it wasn’t too clear, but on OP when I’m talking about the drive flashing and pulsing I mean the light on it.

Do you have other USB devices plugged in?  Maybe a conflict with one of them?

Could there be a bad spot on the hdd?  Have you run CHKDSK?

Very strange situation.

Good shout, I do have a KVM plugged in which I plug all machines that come in into.  

I do run regular chkdsks though, and this problem has carried over 2 PCs with fresh installs, but the conflict definately sounds like a winner.  I’ll test that out with a lappy on Monday.

Ok, so I tried the laptop with and without the KVM, works flawlessly.

Tried in Safe-mode on my PC, stick works flawlessly

Tried the stick in both my colleagues PC’s, get the same issue on first one, works fine on the second, so I took a note of all programs installed on my colleagues PC’s, then found which programs are installed on both mine and colleague 1’s PC (the one not working) then cross referenced that with programs installed on colleague 2’s PC (the one working) and highlighted all programs installed on mine and colleague 1 but not on colleague 2’s

I then installed these programs individually onto the laptop, restarting it and trying the stick at least 3 times after each restart but I can’t replicate this issue on the laptop.

My current PC is Ent x64, old was Ent x86.

Colleague’s both run Pro x64

Laptop running Ent x86

Currently doing full windows update to latest on laptop, though considering this issue was present on my old PC 6+ months ago I don’t see this changing anything, but hey…

Anyone know of a program which can monitor and record the PC status in depth so I can try see if something’s running or making requests when I plug the stick in?  Event viewer has nothing, and all I can get from task manager is that the SVChost.exe process jumps up in RAM and CPU when I plug it in.  Not sure if there’s a way to identify the specific service running under SVChosts which is taking up the extra resources?

Aren’t pcs fun??  :smileyvery-happy:

Thanks for the update Slaverty.

FWIW I have a USB stick that boots fine in everything, except a new netbook’s USB 3.0 port.  It works fine in the netbook’s USB 2.0 ports though. :dizzy_face:

Maybe your BIOS needs to be updated!!  Or maybe it has a setting that needs to be changed!!?

Oh, so much fun.  Definately the right career choice I took going into IT…  hehe.  Who knew a bunch of switches, logic gates and transistors could be so tempermental!

Could be something with the BIOS, all USB 2.0 ports on here though.  However, I have a bootable VHD on my PC containing a windows 8 install, and the stick works fine on that.  When it gets quiet on the desk I think the next thing I’ll try is reinstalling Win7 Ent x64 on a VHD and make that bootable, then slowly rebuild the virtual to the same spec as my current install, see at which stage the issue starts occuring.

Much appreciative for the suggestions though guys :slight_smile:


Ok So it appears to be working again.

The other day I uninstalled a bunch of applications and reformatted the drive and now it seems to be working.  This time I reformatted using disk part, going through the whole cleaning the device and creating a new primary partition then marking it as active, previously I formatted through either Windows, in the drive properties, or through gParted, with both custom and default allocation table sizes.

So I don’t know if there was some error in the partition itself which caused certain machines to not read it, maybe due to some software installed.  Before formatting I took a back-up of the whole drive and then restored it after formatting so it couldn’t be any data on the drive, and I’ve ran several chkdsk’s on the drive previously.

I’m baffled but glad it’s working again (At least for now)

I have installed the applications I uninstalled onto my virtual but can’t reproduce the issue, applications if anyone’s interested were

Intel Rapid Storage Media, Synctoy, Intel Management Engine Components, HTC Sync, Blackberry manager, Opera, Plex, SetACL, VLC and HxD, though apart from the first 3 all were installed after the issue first occured, and as far as I know there’s been no changes on my colleagues machine.

So if anyone comes across this issue of their USB stick failing to load on certain PC’s after the second or 3rd use, try doing a full re-partition & format via DISKPART (select disk X, clean, create partition primary, select partition 1, active, format fs=ntfs quick, assign)



Hey Sean.

Thanks for the update.  Happy to hear you got it working.  Though surprised at the effort it took.