My SanDisk Cruzer blade won't show up on my pc

Hi All,

I am having an issue with my cruzer blade.

My computer recognizes the drive but it won’t show up on my pc.

I though I should assign a different letter to it or format it but on disk management it appears like this:


Altough the driver seems to be installed (also tried re-installing, didn’t work :/) :


I have also tried on different USB ports and on a different computer.

Any advise on what to do?

Is it fixable?

Thanks in advance, Gal.

I am having a similar problem, I was able to format on a different computer but still now luck

I cannot believe 2 other users have experienced the exact same issue as myself at around the same time.

SanDisk I have multiple USB drives and SD Cards from your company and have been a loyal customer.

This problem is unacceptable with recovery software not being able to view any of the files that existed.

The 4GB Cruzer shows up in computer management but has 0% utilisation and says it needs to be formatted.

Supplementary to this I have a 32GB SD Card which shows files within a phone but overheats and shuts down on any PC.

The exact same problem occurs with a card reader which is a major problem not experienced until recently.