Sandisk clip plus 8 GB not working after format

Hello there,
After a while using my clip plus 8GB it just froze, so I formatted it on my Windows PC, now it does not even turn on, when i connect it to my PC with the power button and center key pressed down it reades as (31 MB) capacity and I can’t open it or even format it.
What should I do, please advise…

Sorry to be the bearer of bad news, but there’s nothing you can do. Most likely the internal memory has been corrupted.

Here are some steps you can try anyways:

Remove the MicroSD card. Then with it connected to the PC, make sure it shows in my computer. Press and hold the power button for 30 seconds. The drive in my computer should disappear. Disconnect from the computer and press and hold the power button and left arrow simultaneously (or power button and volume down). If it turns on, continue to hold the buttons until it completely loads. Navigate to settings/system settings/usb mode and set it to MSC (if it’s not already) connect to the computer and do a firmware upgrade (or downgrade if you’re already on the latest). If you are successful in getting it to turn on, you’ll most likely notice that some of the text is gibberish. That’s a tell-tale sign of memory corruption. Firmware upgrade might help, but I was never able to get that far with the one I had.

I don’t have high hopes. I suggest selling on eBay for parts. Might be able to get $15-20 off it. You can get a used one for about $35-45.

Hey Victor,
Thank you for the advice, I tried what you recommended couple of times, eache time I got different massages, first time it said (Fat is corrupted please connect device to PC and), when I connect the device to PC it just shuts down. Second time it said (No partition found) (Plug USB cable), when I plug the cable it says (Bootloader usb mode), what I can do??
Why is it giving these massages? what could I have done to avoid this problem in future reference? (cause I like this MP3)

  1. When you first formatted with your computer, did it say format successful? Did you see an empty drive?
  2. Before you formatted, did you have Rockbox installed?
  1. When I first formatted with my computer, yes it said format successful, yes there was an empty drive but I saw that only 1 time after format, now when I connect it I see the drive but I cant open it and it says (you need to fomat the disk befor you can use it).

  2. Yes I had Rockbox on it.

You’ll need to bypass the Rockbox firmware and boot into the original firmware to do the firmware update.

  1. Press the left arrow (or volume down) when booting up to get to the Sansa firmware.
  2. Connect to PC in MSC mode
  3. If drive is available, proceed with firmware update by copying clippa.bin to the root directory of the drive.
  4. Initiate firmware update by unplugging the player from the computer.

If the player doesn’t show correctly when connecting to the PC, then the only thing left for you to try is the Sansa AMS Unbrick procedure. If you want to try that method, you’ll need to disassemble the player and have decent soldering skills.

Hello Victor, thank you for replying,
I tried to power the mp3 with the volume down key and power pressed, It said (No partition found)(Plug usb cable), then when I connected it to my PC with the center key pressed, it said (Bootloader USB mode) and showed me 2 Removable Diskes which I can’t open.
Please advise…

So I rockboxed one of my clip+ players to try and see what you were seeing. I formatted the player after installing rockbox, and got a bunch on gibberish text on the player. After turning off, then on again, I got the error in yellow text:
“Loading firmware
File not found”

Then the next screen showed blue text and the error:
“Plug USB Cable”

Plugging the player into the computer showed:
“Bootloader USB mode”

In my computer, I had the player show up as 3.65GB and completely empty. I copied the .rockbox folder back onto the player and it booted back into rockbox with no issues.

Connected player back to my computer and deleted .rockbox folder and disconnected player. Turned off player, then turned back on while simultaneously pressing left arrow |<<
The original Sandisk firmware loaded just fine. Went into system settings/USB settings and changed to MSC. Connected to PC and it showed as 3.65GB with some files/folders preloaded by the player. Loaded a stock clppa.bin file onto the player root directory and disconnected. Player finished updating and turned off. Turned back on and booted into stock firmware. This procedure deleted rockbox completely from the player.

If you’re having issues with the player showing up in the computer as a useable drive, then the flash memory on your player is most likely corrupt. You may be able to try the SansaAMS fix, but more than likely it’s a lost cause.