Sandisk C150

Hi,
My MP3 player suddenly stopped working - the screen went blank (the player turns on and off, but no menu appears) and it won’t register as connected to my computer. I have looked on the website and all I can find is recovery software for the 200 series. I called support, and the infuriating email maze tells me to email support. I have done that, but after searching other forums, I am not hopeful. Has anyone had this problem and had is successfully solved?

I encountered almost identical problem with a C150:  turn it on, see normal SanDisk flash screen, then blank menu screens.  Can see the arrows, but no text at all.  Fresh battery = not the solution.  Looks like a SanDisk timebomb license finally timed out?  Notice your post is a week old with no response from SanDisk … looks like time to replace the MP3 player … any guesses which mfg will NOT be considered?

Same problem here.  Everything was working great, then got “low battery” message, so I put in a new battery, and now I can’t get past turning on the player and seeing the Sandisk logo - can’t get to menus, it won’t turn off, and doesn’t show up in My Computer.  Is it dead?

Hey guys,

The main goal of this forum is for users to help users. If you feel you would like an official response from SanDisk, then feel free to contact us at 866.SanDisk. That is the number for the Technical Support department. You might want to check out THIS PAGE for more information. If you have contacted them and have not heard a reply, feel free to let some of the moderators of the forum know and we can look into it.

Don’t you realize this board is the Board of Last Resort.  Your phone support doesn’t support the C150, your email support doesn’t reply, and your product doesn’t work!:robotmad:

This board is not a “last resort” for everyone.

If you emailed Support@SanDisk.com with no reply, just let me know or say so in the post and other moderators or myself can look into the case to make sure it gets addressed.

It would be impossible for us to troubleshoot everybodies player that came on this board and started stating his/her issues. So again, feel free ot send an email to Support@SanDisk.com, if you do not hear anything withing 1-2 business days, then say so and we can do what we can to look into the case for you.

Well, Mr. Smiley, here it is several days later and despite both your word and that of the tech support agent I spoke to last week, not a soul has responded to this problem.  In the meantime, my C150 is still dead.  So look through the messages sent from melacondour at yahoo dot com to you with subject line “C150 Urgent action needed”.  And then get someone to respond!  Otherwise, please send me a return authorization.

According to our internal notes, you have already been in contact. I had previously sent you PM’s (private messages) in regards to contacting me so we can get the case taken care. According to the notes, we are just waiting on a proof of purchase to be sent to RMA_Support@SanDisk.com. If you still need assistance you can send me a private message and I would be happy to look into it.

Have same problem. Did send mail…no respond. Seem that i have to go here…someone have news? Mr. Smiley Why won’t you resume what we can try since we all have the same problem? Anyway… Please help

The alternate tech support number is 866-745-9146.  I found it on another board.  Also, use the email rma_support@sandisk.com.  I spoke to agent names Luis D.  He was really helpful (the first person at Sandisk who was), and issued me a return receipt after I tried a few things while he was on the phone with me.  I sent back the player yesterday.

Big thank’s Jensays. Since i am in Canda, i smell trouble comming up… Can you describe the things that they ask you to do…may be it will solve my problem… I will also send a mail to rma_support. Again Thank’s a lot.

I’m don’t recall exactly what steps Luis walked me through, but basically a few attempts at resetting - hold this down while you press that type stuff.  He also asked me to email him the original receipt from my purchase (which I did).  Supervisors, if you’re watching this board, 10 points to Luis D. for his patience, courtesy and assistance.  If only all customer service agents were as competent it would eliminate the need for these forums.

Ok, my Sansa c150 got the same problem - it did not start, could not be powered off, and did not show up as a USB drive when connected to a computer. Tech Support was responsive and courteous. We took off the battery, pressed on the power button, and connected to USB cable while holding onto the round button inside the circle… We got to the point of adding new hardware, but the adding new hardware wizard always fails with Windows could not find the right software error message - with Windows Media Player 9 or 10. Support concluded the device was dead.

Unfortunately, my Sansa c150 is now 1 year 2 months old now. So it is out of warranty. Support was firm that there was nothing they could do with it. I asked them whether SanDisk could treat this as a customer satisfaction issue and do something about it and the answer was they could do absolutely nothing.

So my c150 is now a piece of trash! I certainly expected it to last more than 1 year 2 months. While I totally understand the technicality of the 1 year warranty, I can tell you that I will NEVER buy SanDisk MP3 players again.

 

Hi  I have the sansa Model C150 and the display lite ups but does not run the names of my songes or the count down the time or the battery display when it starts up???

My wife and I both have Sandisk Sansa c150’s and they both still work great… My problem is I lost the cable to connect to the computer for adding songs…Yes I lost both and yes I’ve already heard the comments from my wife… Does anyone know where I can get another cable. I’m not sure what kind of connector it is for the player. I know the other end is a USB…

                                                                                                                                                                 Thank you

10Same problem. I have <a href=“http://www.edmontonescortasian.com”>Edmonton Escort</a> Reference <a href=“http://www.edmontonescortasian.com”>Edmonton Escorts</a> Version 14 and an Asus <a href=“http://www.edmontonescortasian.com”>Edmonton Asian Escort</a> G73Jh quad core w lots of memory. Very fast on encoding to FLAC. All 8 cores used. Desperately <a href=“http://www.edmontonescortasian.com”>Edmonton Asian Escorts</a> slow going from FLAC to audio (not data) CD. Nero does it in 2 minutes or less.

I have a blank screen on my Sandisk C150. I cannot save anything on this device and a software is gone.

Please advise me.

  1.  Replace battery.
  2.  Reset device. (Press & hold power button for 20-30 secs.)
  3. Recycle responsibly and buy a new player.