c150 Problem

I was listening to my c150 last night and the battery died.  I thought, no problem, I’ll just put another one in.  I replaced the battery, but when I turned it on, it was stuck on the SanDisk screen for almost a minute.  It played some songs from the album I was listening to, but when I go through the menu, it lists all of my music as unknown and under the file WMPInfo.xml.  ll of songs still work when I played them through my laptop, but they won’t even show up on the player itself.

Any Ideas?

try formatting and reloading all the files. that should fix it.

It sounds like you have the same problem as mine. Searching thru the forum, I conclude that this is a very common and well-known problem with the C150.  You won’t be able to format the device either in MSC or MTP mode. Nothing would work. The only solution is to contact Sandisk asking for an RMA. Period.

I was told to upgrade the saoftware. This failed!

Sandisk c150 is the worst MP3 product on the market. I purchased 6 of these players for my kids. 3 Out of the 6 failed within a very short time.

My problem? One of the replacement players DIED. And i Was told my support I was out of luck. This player is a few 6 months old. It was a new player. I should have a year warranty.

My HP laptop dies with 2 weeks left on the warranty. HP gave me a new laptop better and faster with one year warranty as all new product have. WHY NOT SANDISK?

 Please help me.

Thanks Roger

Roger, I have looked into your case and researched the original purchase dates of the product.  As unfortunate as it is, it seems the warranty on your product ended approximetly 4 months ago. Had this timeframe been a little closer to home, we may have been able to figure something out.

When a player is replaced, it carries the warranty of the original product, it does not extend an extra year.

Feel free to PM me if you have any questions.

Hi Everyone~

My Sansa C150 will work fine for a while but then the screen will start flashing and the LCD screen graphics will get distorted and then it will freeze. I tried reformatting the mp3 player in Windows Media Player but the issue still happens. I also tried the 20 second reset on the device and that didn’t help either. I read that reflashing the firmware might fix the problem but I cannot find any flashing utility or the firmware. The firmware I have on the mp3 is 2.0.007A. I also tried to install the Sansa Updater application and all it says is “no updates available” with no options to reflash.

Can anyone help?

Thank you.



That player is prehistoric. It’s so old SanDisk doesn’t even have a firmware posting for it here on the forum.

You might get lucky if you google it; someone might have a copy somewhere.

Hi Tapeworm~

Yes the C150 is ancient, but it runs off of one AAA battery. I never have to worry about some litium battery going bad over time as with the new mp3 players. I just carry a couple of rechargable AAA batteries when we have some kind of event and I don’t have to worry about recharging the mp3. I did search the internet to try to find a flash utitlity for the firmware but I couldn’t find it. Thanks for the advice though in case I hadn’t thought of that.