rhapsody to go playlist and transfer HELP!!!!!!!!!

ok, I am new to this so warning… My player was working fine, I didn’t have any problems transfering my playlists to my player then suddenly yesterday it all went straight to h*ll!!! At first I could transfer a playlist but it only showed up as “New Playlist” not what I named it. Now nothing will transfer. Rhapsody will say “transferring 2 of 30… 12 min remaining” however it will say that for hours and hours and hours!!! I have tried reformatting, setting the usb modes, erasing it all resetting factory settings and everything else I have read on these boards. I have tried at least a hundred different ways and still nothing. I now have an empty music player and rhapsody says it is transferring but its not. Has anyone come across this before and does anyone have a solution so I can get my music on my player. I am so frustrated right now and there seems to be no hope in sight. Please help!!!

are you using the rhapsody subscription service or are you using your own mp3s? if it is your own mp3s dont use rhapsody at all just drag and drop the files or use windows media player to sync the files and create playlists. 

I am using the rhapsody to go subscription, not my own mp3s

i guess i should have read your post title better since you say you are using rhapsody to go. 

here are some things you can try

-Rhapsody 4.0 has some helpful files with it (typically in C:\Program Files\Rhapsody) 


-Delete Helix Licenses

-Update Helix Components

-Update Windows Components

-Recreate the DRM system folder 

  1. Open My Computer, go to Tools, Folder Options, View tab, uncheck “Hide protected operating system files.

  2. Go to C:\Documents and Settings\All Users and rename the DRM folder to “DRM Old.” (If it will not let you, then close all other programs and try again.)

  3. Reboot the computer and restart Rhapsody/Napster.  It should generate a new DRM folder.

-Format using Windows Media Player  

Version 10: go to the Sync tab, click on the “format storage media” button.

Version 11: click the down arrow below the Sync tab, Device options, Format

-Install the firmware update if not done already 


This happened to me also, a few months back.

It would take hours just to transfer a few tracks.

What I did to fix this was in Rhapsody go to Tools>Preferences>My Library

Then choose “Download tracks to hard drive” instead of “Add tracks as streams only”

This should speed it up.

Finally after trying everything else that worked. Thank you so much!!!

You’re welcome, I’m glad to help. :]


Is there a way to re-create the DRM folder in Vista?

Also, I’m having a similar problem; every time I try to download my Rhapsody playlists to my 8GB Fuze, I get to watch the number of errors skyrocket (e.g., for a playlist of 100 songs, I’ll get about 90+ errors). I’ve changed Rhapsody settings, un/reinstalled it, reformatted my Fuze (just acquired this week) about 7 times–through WMP11, the device itself, and the
“recovery mode” where it shows up as both the F: and G: drives.  Is there something else I need to do, besides chuck it and buy a new one?


I’ve been having similar problems of taking forever to transfer non purchased songs from R to my Sansa.  I was going to try your DRM solution but I got a pretty stern warning that it wasn’t recommended by Microsoft.  Not being computer literate I decided to ask you if I should worry.  Something to the effect that if something goes wrong with some of the involved files the computer may not work.  What do I know?

I tried several other solutions mentioned in other posts like deauthorizing and reauthorizing, reset secure clock, license, set to MTP, and set preferences in the R library to “download tracks to HD” rather than streaming.  Seemed like some of this mightr have helped for a short while but then it was back to problems. 

Any assistance would sure be appreciated.  This is one frustrating combination.