Fuze and Rhapsody

My fuze downloaded about 20 songs from rhapsody and now it doesn’t seem to be transfering at all. Rhapsody says it is, but the Fuze only says its connecting and no matter how long I wait, im not getting any new songs. Any advice?

Could be the cord. You’d have to try a replacement.

But first, call Rhapsody customer service and see if they can help you. You’re paying them.

I have used Rhapsody for over five years and the past few years with my Fuze. One thing is is has NEVER worked correctly at all with the fuze. The progress bar that shows at the bottom of the window is always wrong it will say transferring 2 out of 25 for Minutes and if you look at the screen on the Fuze it will say “connected” not “writing” meaning the songs already transferred.

This is a known flaw and Rhapsody does not care whatsoever about it. Many people have complained, and called and they always try to blame it on your computer or the Fuze itself. Sorry I do not believe that when many people have the same issues. I am even on my 2nd USB cord (first one was damaged to where it would not plug into the Fuze anymore) and with both cords Rhapsody acted the exact same. 

A few other issues are some of the playlist will either all the way disappear off the Fuze, or songs will get pulled out of the playlist/off the Fuze. This mostly happens when I connect the Fuze before opening Rhapsody (Which will also cause it to hang and say “not responding” in the title bar of the window) 

Every so often it will all go crazy and when you plug your Fuze in, Rhapsody will show the lil triangular ! icon and give some stupid errors or say you need to authorize your Fuze. When this happens I have learned it is easier to just FORMAT, to wipe it clean then re authorize it. When I do this the software seems to work flawlessly the very 1st time i add music to it but once i unplug the USB and try again another time, the stupid progress bar hangs again (example sits on 2 out of 25 for 45mins) 

Last and most importantly, Do not make long playlist (100+songs) whenever I have tried to transfer them Rhapsody always craps out I usually have to close it and restart it. Try to keep your playlist smaller and only transfer one at a time, when I would drag 3, or 4 at once even it would get stuck and crap out midway thru the 1st one. 

Rhapsody is well aware of these issues and basically they do not give a hoot. Go look at the forums on Rhapsody’s website if you do not believe me. 

Why don’t you try RealPlayer. It’s made by the same people as Rhapsody (Real Networks), so it should work with Rhapsody songs. I’ve used it for years, so I know it at least works. The program is free to download, so you don’t have much to lose.