Rhapsody problem

Alright.

When I have my Fuze in on Rhapsody trying to transfer songs onto it, it tells me to purchase the song. I tried authorizing it. It said to click on the device icon and press authorize. There is no authorize button. I’m already signed up for Rhapsody ToGo, but I can’t transfer songs. Solutions?

Your Sansa is in the wrong USB mode for subscription content.

If you look at your Sansa in the sources pane of Rhapsody, it will display in CAPITAL letters when in MSC mode.  Unplug your Sansa, and go to Settings > System Settings  USB Mode > MTP.

Your device should now list as “Sansa Fuze 4GB” for example.  Right click on the device, and Authorize will now be available.

If the Fuze is not recognized in MTP mode, the issue may be with Windows Media Player, which contains the MTP drivers.  Let us know if the Fuze communicates in MTP mode.

µsansa