I thought this thing was supposed to work with Rhapsody?

I got a new Fuze this weekend. I was really excited to try Rhapsody.

So, I popped in the little CD that came with my Fuze, signed up for the 14 day trial, gave it my credit card number and everything, and got ready to drag and drop songs and albums-

-but it’s asking me to pay for songs. It says I don’t have a Subscription device.

I did some googling and saw that a lot of people have had this problem. I tried everything that’s seemed to work for everyone else but it’s still not working for me.

I double checked, and I do have the latest version of Rhapsody (4.545), and I did sign up for Rhapsody To Go.

I tried AutoDetect and MTP for the USB settings.

I downloaded Windows Media Player 10 (I previously had 8).

I tried switching USB ports.

I uninstalled and reinstalled Rhapsody.

I tried all these steps again, restarting my computer between each one, and nothing has changed.

The “Authorize” option for my Fuze simply does not show up when I right click on the icon. The SANSA FUZE does show up as a source, but right clicking only shows “Device Options” and “Disconnect”.

Tools, Preferences, My Devices tells me Rhapsody needs to do an update to support my device, but as stated before, I have Rhapsody 4.545, which I just downloaded today.

The My Account, Manage My Devices screen is useless. It just tells me to click on the non-existent “authorize” option I mentioned above.

… help?

To add to the fun, I can import songs from CD and put them onto my Fuze, but for some reason, it’s dropping the artist name, album name and genre. It lists all three as “unknown”, even though they showed when I put the songs in the Library before moving them to the Fuze.

Message Edited by tailsbob on 11-30-2008 09:52 AM

Wow, and this is where the package insert told me to go for customer support?

I had the same problem and it was fixed by simply installing windows media player 11.  Since I did that my fuze and rhapsody are playing together nicely.

I have nothing to add to solve your Rhapsody problems but I thought I would add a comment about your post.

It has to be one of the best first posts to this forum that I have ever seen. Any and all information that someone would need to help you is there. You detailed what actions you have tried, you have detailed that you tried to find the answers yourself, you detailed the error messages.

Spend more than 10 minutes on this forum and you get VERY tired of the “My Fuze won’t work, please help” posts very quickly.

The only minor thing about your post is you didn’t post what firmware version you have on your Fuze and if you updated it. Seeing as it comes with the Fuze Rhapsody probably worked with the first firmware version and I have no idea if there were bugs related to Rhapsody fixed by updates.

Tailsbob, you have shown wisdom in your post, very refreshing.

It’s easier to help you along, knowing your steps taken.  When the device is seen in MSC mode, it identifies in the Sources pane in capital letters.  The device needs to be recognized in MTP mode (it will show in Caps and Smalls).

You’ll also, when right clicking on Sansa Fuze, have the important Authorize option.

Let’s get MTP active, the virtual mode for WMDRM transfer, and you’ll have a working Rhapsodt To Go subscription.

You have WiMP10, so go one further step.  Open WiMP10, and click on Help > Check For Updates, and install WiMP11.

There was an interesting post this morning that links to the Sansa Knowledge Base.  Scroll down to SOLUTION 5, and also install the Microsoft MTP Porting Kit.

I’ll be back in a wee bit, and will check in again.

Hopefully, you’ll ahve the Sansa showing up in Rhapsody 4 as an MTP device, and you’ll be up and running.

Catch you in a little bit…

Bob  :smileyvery-happy:

Has anybody noticed that the original post was dated almost 2 1/2 months ago? Or that the original poster never made a follow-up post (only credited with 1)? And he hasn’t even logged on since Dec. 1, 2008!

Now he might still need help, but it’s highly doubtful that he would simply lurk here waiting for an answer to his problem for all this time. A more likely scenario is that after he hadn’t received any responses to his request in 2 days, he got the answers he needed at the Rhapsody site, just gave up, or figured it out on his own. :wink:

Hehe, good catch, Tape.  But, the information will help anyone in a similar situation.  Hopefully. 

Bob  :smileyvery-happy: