Refresh Database Problem - Help!


I have a problem with my sansa e260 v1.  I was copying some mp3s on it, and when I disconnected it from my computer, the device froze when completing the “Refresh Database” function.  The screen will either go blank, or display some colour lines.

I took the battery out, as this was the only way to turn off the device, but when I turned it on, the same thing happened.  As soon as I connect the player to my computer, it tries to “Refresh Database”, and freezes when it’s about 70% complete.

I am able to get to boot to recovery mode, but I get a message that says “enter USB2.0 MSD mode”.  I can’t change the “mode” because the player will freeze as soon as it tries to “Refresh Database”.

Neutron Bob provided a solution to someone with a similar problem, but when I tried it, it didn’t work.  I copied the files linked in the post onto the “16MB-FORMAT” recovery partition, but this does not remedy the problem.

Any help on this problem would be greatly appreciated!  My sansa e260 has worked great until now. 

After 2 hours of messing around and searching the forums, I was able to successfully reformat my e260.  The solution that worked was creating a new folder named sansa.fmt and copying on to the player while in recovery mode.


Just like they used to say on the ‘X-Files’ . . . the answers are out there.

Or here, actually.

Glad to hear you were able to figure it out! :smiley:

 Add your music back a few albums at a time. Something—probaby an unconventional ID3 tag–made the unit unhappy. So add the albums a few at a time, let it refresh, and then add more. If it goes bonkers again, you’ll know which album gave you trouble.