e250 cant refresh database

Yesterday I re-formatted my sansa player due to some video problems and re-uploaded all my music again, I’ve donde this several times and never had problems before, thats when my sister asked me if I could also upload some of her music and said yes. All the media transfered well and had no problem with that, I disconnected the device from my computer after the battery was fulled charged. As normal the device re-started and the “Refresh Database” message appeared but half the way the screen changes to green, blue or white plain color and no button responds. I tried connecting it back re-format it and not upload my sisters music since I think thats the problem, but everytime I connect it the same thing happens: “Refresh Database”/screen changes color/no responding.

I cant go past that, has anyone else had this problem?? Is there a way to fix it or something??

Please I need some help ^^;

Thanks before hand.

-Lokikola

Yah i’m having a similar issue, my players been working PERFECT, and i love the new media player. But just about a hour ago I uploaded parts of 300 the movie, and some Robot Chicken episodes, and well… It wasn’t Fully charged, but pretty close so I took it off the charger, and it “Refreshed the database” And it ranges from anywhere too Done, too 75% when it turns BLACK!!! the wheel stays blue of course, so I pressed every button imaginable, and I took the battery out I tried everything. Final I just called customer service, and they did the debugging crap, and well apparently you, and me have installed “Corrupt files” And like usualy the customer service for Sansa is AWESOME!!! I love these people. But they never sent me the “Files” too fix my player… I have too call back tomorrow, and i’m not too happy about that, but atleast the guy I talked with was nice! :smileyvery-happy:

I’m having somewhat of the same issue as you two are. When i plug in my player it opens with the “Refesh database” screen and then not even half way it just freeze. After when i try to shut it down so i can format it, it won’t let me do anything. Does anyone know how to fix this problem?

There are many, many, many threads about this “refreshing database” freezing issue. If your player is the regular e200 player. Try this link Here

Make sure you put your player in the recovery mode. Turn off the player, push the hold switch over so that you see orange, hold the record button down, and then as you are holding down the record button, plug the player into the computer.

Then try the program from above…

OMG!! It worked perfectly thank you, I never knew anything about this recovery mode, I was never able to read the users manual, my computer just doesnt want to open it, not even the one I downloaded from here, I’ll keep trying, maybe my acrobat reader is too old for it to open it…

Anyway, thank you, it is working perfectly now, as good as new!! ^^

-Lokikola

:slight_smile: No problem!!! Glad it worked for you!! :slight_smile:

If I can be of anymore help let me know! Or just make another thread :smiley: