"Refresh Database Do Not remove SD" error

My express works fine until I insert a Kingston MicroSD 4 gb card - then it just goes into this “Refresh Database Do Not remove SD” screen and after a few seconds, the screen goes blank - if I wait too long, the device powers off (like a couple of minutes despite the fact that power off is set for 30). If I press any button within a few seconds of the screen going blank, it shows the same message as above. I have updated to the latest firmware. I have reformatted the internal drive. I cannot get access to the external drive from inside the player to format it. Any help is much appreciated.


Try this: http://forums.sandisk.com/sansa/board/message?board.id=express&thread.id=1143

I have updated to the latest firmware.

My problem is that my 4 gb microSD card is not recognized - I can’t even get out of the “Refresh Database Do Not remove SD” screen to allow me to access the setup menu.

Is there a known issue with a Kingston 4 gb microSD card?

If I stick the card into the player, then plug it into the computer, the computer recognizes the sansa player - both the internal and external cards. I can write to the external card fine during this phase. When I unplug the sansa, it rebuilds the internal memory data,  then I get the above refresh database screen of death.

Any ideas/suggestions ? much appreciated.

I only have a 2GB card and it does take a few moments to sort out when it is full.  My screen will go blank during the sort but come back when finished.  Try emptying the card to a few files and see if the problem still persists.

I have the same problem with my 4GB Card  

I have had the same problem and I believe I have figured this one out.  I read that the Express can only read microSD cards formatted in FAT16 or above.  I noticed that the card I bought was formatted in FAT.  So, I reformatted the card to use FAT32 and the “Refresh Database Do Not remove SD” screen no longer froze.  To reformat, hook the microSD card into the standard SD converter and plug it into a computer that has an SD card reader.  Go to My Computer (if you are using Windows), right click on the card and select format.  Then make sure to select FAT32 and hit OK (you can click the quick format option if you want).  Be sure to back up any files you want to keep. 

Registering to say that I had this problem with my 2GB Kingston, and RoboBlaster’s solution worked perfectly. Anyone who got here by googling the error message, do that.