Random System Hangs - 100 % SSD Usage

I’m having some significant issues with a new PC build.

I have a 240 gb Ultra II.  I have 8.1 installed on it, as well as a few other programs (I’m at 182 GB free).  Now, at random times when I’m using my system, everything will suddenly hang.  All programs become unresponsive, the mouse sometimes locks up, ctrl+alt+delete won’t do anything, etc.  This lasts for about 30 seconds, then everything usually returns to normal.  I leave task manager open at all times now, and it shows that during these hangs, my SSD “active time” jumps to and stays at 100%.

These hangs don’t seem to be linked to specific software.  They occur randomly, even when my computer is under no significant load.  I’ve already tried a clean install of 8.1.  I’ve tried disabling superfetch/prefetch and other background system processes.  I’m very confident that I am free of any viruses/malware.  I’m suspecting some sort of hardware issue, but the SanDisk Dashboard shows that my disk health is fine.  My firmware is also up to date.

Has anyone had similar issues?  Any advice or thoughts?


seems to be a strange issue so i would recommend formatting the drive and perform once again a clean installation of the os, also you can try to do a google search to see if your motherboard has common issues with ssd drives.

if nothing helps you can also try to contacting the sandisk support for further assistance


Hi Deponia,

Thanks for the suggestions.  I’ve already tried a complete format and reinstallation of windows, and the issue still recurred.  I’ve also tried a repair installation from the windows disc, and that also did not eliminate the issue.

After a couple google searches, I’m not seeing much about compatibility issues with the motherboard.  I have an AsRock H97 Pro4.

I’ll try to contact sandisk support.  I’m getting advice on other forums as well, I’m going to try increasing my virtual memory.


Did support solved your issue? I’m having the same problem. It also doesn’t concern any specific application. System hangs randomly for 30sec up to 1min. The only difference I have is Windows 10 (10.0.14393) and that system is responsive during 100% disk usage. However most appliactions does not work at all on that time.

I’ve made a screenshot (attached). As you can see when there is 100% of usage, all transfers on disk are droped down to 0.