SSD bad?

I built a new system with ASROCK extreme 3 mb and a sandisk ultra 128mb SSD as boot drive. Everything worked fine for about a month and now boot hangs on windows logo and when reset drive is not detected by computer. If I power down system it does same thing, hangs on windows logo. I replaced drive with my old HDD and system boots up fine, however if I install SSD as secondary drive the HDD boot hangs for a bit then boots into windows with no SSD in drive list. Is my drive bad? I can not think of anyway to access the drive even if there is a fix?

I would try booting up and using your windows installation disk to see if you can repair the install. If that does not work the drive may be bad. in that case you would need to contact sandisk support. 

I tried windows disk and it does not detect the drive.

in that case it sounds like a bad drive. you should contact sandisk support. 

Looks like a hardware issue. Maybe check the warranty. 

I had a similar problem.  Windows would start to boot off my 120Gb Ultra SSD, but hang.  Ubuntu (which loads faster) would boot, but then be unable to access the disk (which caused many problems, but it kinda functioned).  I found that my drive seemed to work for less than a minute after powering on, seeming to make my data unretrievable. :frowning:

But I found a solution:

I put the drive in an external usb docking station, and booted off an old hard drive with my SSD powered off.  If you don’t have a old drive a Ubuntu CD or flash drive would work just fine.  Then I thought about which files I wanted, and planned. Then I wrote a command line which looked like

sudo mkdir /media/sdb1

mkdir ~/backup

sudo mount /dev/sdb1 /media/sdb1; cp -r /media/sdb1/Documents\ and\ Settings/tbogue/My\ Documents/projects ~/backup; sudo umount /dev/sdb1

Then, before hitting enter on the mount/umount line (which should all be on one long line) I powered on the SSD in its docking station.  Since it worked for 20 seconds, I could retrieve my data 20 seconds at a time.  Fortunately, the SSD was very fast so 20 seconds was a considerable amount of data.  Then I powered it down and repeated the process to get more and more data off the drive.

One might be able to do this in windows by either

A) being quick with your mouse

B) writing a script.  I’m not familiar with windows scripting.  It might be possible.

I’m not sure how Windows would handle the failure of the drive since you can’t unmount.  You may need to reboot each extraction.

I’m not sure if this is the problem you are having, but if so, I hope this helps you get your data back.

Good luck!

Always believe that good things are possible, and remember that mistakes can be lessons that lead to discoveries. Take your fear and transform it into trust; learn to rise above anxiety and doubt. Turn your “worry hours” into “productive hours”.While taking ( ]new york asian escort my boat ( ]new york asian escorts down the inland waterway to Florida a few weeks ago, I decided to tie up at ( ]new york escort Georgetown, South Carolina, for the night and visit with an old ( ]new york escortsfriend. As we approached the Esso dock, I saw him throughYou will find happiness when you addopt positive thinking into your daily routine and make it an important part of your world.

Bump, i have this problematic too, but i’d like to image the whole disk.

Actually cp is not working nicely for 50gb + files. I’m currently exploring 2 ways:

  • one way with rsync, which seems to works better than cp -ru

  • another way based on dd and incremental raw dumps