My 1TB portable Extreme SSD is causing my computer to hang at the boot screen if I reboot while it's plugged into a USB 2 port

I have a Lenovo V520 PC. I got a 1TB portable SanDisk Extreme SSD drive last week, and earlier today encountered an issue where my PC got stuck at the Lenovo boot screen and wouldn’t boot into Windows. After performing a series of tests that involved me restarting the machine numerous times, I found the SSD to be the culprit. The computer booted into Windows very quickly whenever the drive was removed from the machine or inserted into a USB 3 port. So far, these are the things I’ve tried with no luck:

*Updated my computer’s BIOS to the latest version
*Turned off USB legacy support in the BIOS settings menu (this is supposed to fix kind of issue in many cases, but hasn’t done)
*Tested the SSD in different USB ports
*Run Lenovo’s hardware diagnostic wizard, which reported no onboard hardware issues with my PC

If I boot up the computer from being powered off, rather than rebooting from Windows or the BIOS menu, it boots into Windows 10 but significantly more slowly than with the device removed - it takes longer on the BIOS screen, and Windows seems to freeze up for about 30 seconds to a minute at the login screen, though the OS runs at its usual smooth speed once it stops freezing. In addition, Windows does not seem to recognise the device in Explorer when powered up, meaning I have to remove and reinsert it. It appears to boot normally with it inserted in one of my computer’s USB 3 ports, which it’s ultimately designed for, but I prefer to have it inserted in one of its USB 2 ones as I’ve found the difference in speed to be only slight, and prefer to have it at the back of my machine, which only has USB 2 ports.

Does anyone here know what could be causing the issue, given the things I’ve already tried?