My SSD Hard Disk freezes intermittently.

Hi,

A week ago I purchased a new Sandisk 120GB Extrime SSD and I installed in my laptop (lenovo x61 tablet).

And I installed Windows 7 on it. It was really faster than previous HDD but it strated freezing intermittently.

In order to prevent I tried :

  1. AHCI set in CMOS setup

  2. disabled superfatch

  3. disabled disk defragment 

but still freezes intermittently.

Is there any other things that i can try to prevent freezing?

Do you get any error or blue screen?

Hi,

i too have the same problem. Just got the SanDisk Extreme 120gb disk.

Hardware in my pc is

Asus Striker II Extreme, Nvidia NForce 680i SLI,

Kingston 1066mhz DDR3 4gb

Q9450 Core2Quad

Windows 7 Professional

If i boot to my ‘old’ 7200rpm maxtor I have no problems at all. But especially when writing files to my NAS or using Grabit for news, it just stalls/freezes. One by one applications start to become unresponsive, in the end even the mouse stops working. After about 20 seconds the entire system acts like nothing happened.

I installd a fresh, official and original MSDN windows 7 professional that i got from the university. Also installed ALL drivers, and ALL updates. Windows is activated and genuine.

have you find a solution yet?

Hi Kongji, 

Lenovo x61 bios is limited to SATA 1.5gbps although the chipset supports SATA 3.0gbps

You might want to flash to the hacked bios which enables SATA 3.0gbps

http://forum.notebookreview.com/6501443-post75.html

I used the hacked bios to enable SATA 3.0gbps with T61 & Kingston V+100, and it works pretty well.

If this bios helps, my guess is that maybe the Sandisk Extreme doesn’t work well on SATA 1.5gbps on older hardware?

I too also have the same symptoms you described, the odd thing was that the system was working well for a few weeks with no issue. With no hardware change & minor software changes (program installations), the system started hanging randomly and the computer is no longer usable.

To be more descriptive:

  • The system is completely unresponsive during these intermittent hangs.
  • The hangs seem to occur when a disk read/write operation occurs; I’m not quite sure if switching between windows, opening the start menu, & other minor things GUI interactions actually call on the hard drive, but they also intiate a hang that would last several minutes long.
  • The computer does return to a normal working state as long as you don’t initiate any other actions when it becomes frozen.
  • Boot Up & Shut Down are affected greatly, 15-30 min. to do either. Sometimes Boot Up fails completely.

Troubleshooting Steps to Narrow it down to SSD

  • Checked and reseated Video Card(s) (SLI); booted up system with both, and one or the other; no resolution.
  • Clean re-install of Windows 7 x64 Ultimate; no resolution, symptoms present immediately upon finish of installation
  • Clean install of Windows 7 x64 Ultimate on 60Gb OCZ Vertex 2 drive; no resolution.
  • Removal of other HDDs (1.5 Tb Seagate; 60Gb OCZ Vertex 2) and clean installation of Windows 7 x64 Ultimate; no resolution
  • Moved Sandisk Extreme SSD 120Gb to other SATA ports; no resolution.

Determining Sandisk Extreme SSD was cause:

  • Clean re-install of Windows 7 x64 Ultimate on 60Gb OCZ Vertex 2 without Sandisk Extreme SSD installed; resolved isses: no more hangs, smooth performance.
  • Re-introduced Sandisk Extreme SSD to system; immediately hangs started occurring. Sandisk was clean with no partitions. Able to resolve issues again by removing from system. Was able to again reproduce hanging by re-introducing to system.

I just noticed new firmware update, will update to see if it resolves this issue… any response from Sandisk would be greatly appreciated.

System Specs: i7 975; GTX 590 & 295; Sandisk SSD Extreme 120Gb; OCZ Vertex 2 60Gb; Seagate 1.5Tb; PC Power & Cooling 1200 Watt PSU; 6Gb Corsair DDR3; SoundBlaster X-Fi Titanium HD.

If the issue occurs anytime the drive is connected the issue may be a related to the SSD and the SATA chipset on your motherboard. Can you let us know what type of motherboard is in your PC?

this could be a bad drive as well. did it ever work or has this been hapening since you purchased the drive? if you have a USB harddrive enclosure can you attach the SSD using the USB enclosure? when connected as an external drive do you see similar issues?

Thanks for the reply,

The system was actually working well for a few weeks prior to these issues. As for my motherboard, I have an MSI Eclipse Plus with an X58 chipset and the SATA chipset is the Intel ICH10R and JMicron 362; all the HDDs are on the Intel ICH10R.

Ahh - I do have a USB HDD Enclosure that I could test out - didn’t think of that. Will try that and report back…

one more thing you may want to try. There are some systems that may have compatibility issues with HIPM. By default Windows 7 has HIPM enabled. Try setting HIPM to active. Setting to active actually disables HIPM. Here is a quick link on how to. 

http://www.sevenforums.com/tutorials/177819-ahci-link-power-management-enable-hipm-dipm.html

That SSD uses the Sandforce SF-2281 controller which has lots of problems with freezing in variety of vendors’ SSDs.  Google it and you’ll see.  I have the same issue and haven’t come across a solution yet.  The new BIOS 3.3.2 did not cure it in my case.

All,

Just to report back, the new firmware seems to have resolved the issue. Still uncertain as to what the exact cause was, but the issue is now resolved after the update.

dear sandisk,

as i still have problems with my drive, with 201 firmware, Is there going to be an update for this one?

I still have the issues, despite trying a lot of different manuals.

Or do i need to request an RMA?

regards,

Sebastiaan

Latest SSD firmware, Windows 7 64bit, Asrock Extreme x58 (also latest firmware).

Still experiencing crashes. Is this known to be a drive thing or a mobo incompatability thing? Buying a newer motherboard to unlock SATA3 is an option for me, or swapping it with the SSD in my laptop.

Your life can be enhanced, and your happiness enriched, when you choose to change your perspective.I to (http://www.nyasiangirls.com) ]new york asian escort on the (http://www.nyasiangirls.com) ]new york asian escorts chaotic street in the wind to fondly remember happiness, I (http://www.nyasiangirls.com) ]new york escort was thinking of in the familiar environment yesterday, I was recollecting (http://www.nyasiangirls.com) ]new york escorts joyfully nearby the vast sea, I was tasting sadly under the sob sky, I smiled in front of the mirrorBegin to build your confidence, and work through problems rather than avoid them. Remember that power is not necessarily control over situations, but the ability to deal with whatever comes your way.

I too purchased the SanDisk Extreme 120 GB SSD drive and installed this into a MacBook Pro 2008. I was able to clone over the system / data without a problem. The performance was excellent for about a week. Now Its hesitating constantly. Simple tasks like switching between programs, making windows larger…etc, besides loading programs, will internitantly seem to stall before accomplishing the task. I’m also using a sector check program and it seems to blaze through severa thousand blocks and then will stall for about 20 seconds and then continue to roll through several more blocks. So far, no bad blocks found, but there’s no question that the issue is here.  I even when back to a back-up from last week before the issue was clearly noticable and the issue is the same. So I believe software has been ruled out. I am not seeing errors in the task manager (console)…etc, that point me to any other althernative then to suspect an issue with the new hard drive. I noticed you have posted firmware updates, but they are not mac installable. Is there a way to work around this? I’d loved the initial performance, but now its worse then before when I was using a 5400 RPM drive.  Thank you.

there are downloadable ISO that can be burned to a CD for uopgrading on a MAC stickied at the top of this board. as for drive performance

how much free space does the drive have?

have you enabled TRIM?

how is performance on a freshly installed OS? 

@lewrossi, does your Macbook Pro have a nVidia graphics card in it? I have read of a lot of people with nVidia Macs having issues with Sandforce cased SSDs regardless of vendor. Seems to be an nVidia issue.

Same problem for me with latest firmware (updated to try to solve the freezing problem) on my Sandisk Extreme 120GB.

The computer freezes during about 20s (HDD led on) randomly.

My configuration:

Win 7

ASRock 880GM-LE/FX

AMD Phenom II X4 965

AMD HD 5770

AHCI is activated

No problem with my OCZ Vertex 2 60GB with the same configuration (changed to have more space…).

One last point: the boot time is slower (30s) with my Sandisk Extreme compared to the OCZ Vertex (25s) with more installed programs (older win7 installation)!

I suspect my Extreme SSD to be faulty…

Regards,

Nmut

I too am having occasional freezes.

I have upgraded from a very stable system running a Crucial C300 128G SSD to a SanDisk Extreme 240G - basically for the extra space.

After, and during, a fresh install of Windows 7 64bit I had a number of freezes where I needed to use the big red button to close the system.

If I drop back to the old Windows install on the Crucial, everything works just fine.

I have also had an interesting problem with the instalation of one of the drivers, which I will raise as a separate post.

System is…

Motherboard - Gigabyte GA-X58A-UD3R Rev 1
Memory - Corsair Vengeance 12GB (3x4GB) DDR3 PC3-12800C9 1600MHz
Graphics Card - nVidia GTX 460
System Drive - SanDisk Extreme 240G - Ver R201
Storage 1T Raid 1 Array, 2T Raid 1 Array
Spare - Crucial C300 128G SSD (Currently contains old Windows system)
All in a Fractal Design R3 Case with copious airflow

BIOS, Firmware and drivers all at manufacturers latest.
NB - No overclocking

RzB

for the ones still getting intermitent freezing. have you all tried disableing HIPM? below is a link that explains how.

http://www.sevenforums.com/tutorials/177819-ahci-link-power-management-enable-hipm-dipm.html

I got a SanDisk Extreme 240 Gb disk.

I have installed it in a Toshiba Portege R500 laptop, then I installed Win7 x86.

It worked with no problems since the SSD had firmware R112 installed. Since I updated the SSD firmware to R201 it started freezing as described in this thread.

I tried enabling/disabling HIPM and DIPM but it did not work.

Now I’m writing hoping that someone at Sandisk would understand that there are issues with their new firmware that make the SSD useless.

I hope that someone could tell me if there is a way to downgrade the SSD firmware to the previous R112.

Thanks