Radio Tuner MIssing after trying to update Firmware

I downloaded the Sansa Firmware update, installed software and got to the screen that instructing me to plug in the player, this I did and nothing happened, left it for 10 minutes plugged in still nothing on my pc sceen, but the player now had a little blob on it not the usual display when charging.  After I unplugged the player it said it was rebuilding the databases and then turned itself off.

Figured the software had not downloaded correctly so went to install it again, I was asked if I wanted to un install this I did restarted my machine and downloaded again.

This time when I plugged in the player it said I had the current version.

I now have a funny blob display when I connect my player to pc, I can transfer music, but no radio tuner, music does play.

I have tried  resetting the player, formatting the player and even uninstalled and re-installed the updater but still no joy

Has anyone got any suggestions, as I do use the radio option.

Thanks

Beryl 

Curious - what firmware do you have on the device?

I have 01.01.01 firmware

searchin forum - somebodys aid to goto settings then format - should fix it

I have reformated it from the player and using windows media player, I have soft reset it hard reset it,  and I have done all these steps on three different computers using xp home xp professional and vista, I think the upgrade didnt complete correctly as I  have tried using the upgrade on the three machines too and I can not get past the 20% point when it says no upgrades available.  Music plays, its just getting the e audio books and the radio options to work, and these two are the two functions I used it for!  I have an on going dialog with sandisk help  desk right now so I guess I will wait and see if they have any other suggestions, Its just so frustrating if only I hadn’t done the firmware upgrade thing it was working fine before that.

Hello there
I have the same problem. If you have an answer from the support please post the solution.
Thanks a lot!

Hi

Well I emailed support for help, and they had me do all the reset reformat stuff and it didn’t to any good,  I tried on three different computers with three different operating systems and still no joy.  So today they sent me an RMA to return it. 

But I had returned it to the retaillers as I had only had the thing since Mid June and they replaced it.

s