Radio disappeared

Hey all, first post here, hope someone can help. Apologies if this is an issue that’s already been addressed.

I half-charged my Zip today (all I had time for) and updated it, and now the radio option is missing–not like it won’t work, but that it’s just not there. Was working fine prior to this (though it’s been sitting for several weeks with no charge). The updater program also wouldn’t start for some reason, but after I fix that, reinstalling the firmware update is my next step. 

(If it helps, I will admit that it went through the wash once, but that was months ago and it worked absolutely fine after drying for a week in a bag of rice.)

Did anyone else have this problem? Anyone have any idea what’s going on? 

I would try a manual firmware reinstall–that could fix matters.  (See the firmware upgrade sticky thread at the top of the forum.)

You also might check the Customize option in the Settings menu where you can set your main menu items to show or not show. Maybe it’s set to off.

Normally a firmware update will erase all your personal settings including these, but who knows. What Region did you select after updating the firmware?

Thanks for the replies. I have manually updated again and have checked under Customize–the radio option isn’t listed there either. Guess I’ll contact customer support next. 

Again, what Region did you select after updating? Maybe the FM function is banned or otherwise disabled. The older model Sansa players did not have FM Radio function in the units sold in Europe. I don’t know is this restriction has changed or not.

If you selected Europe as your Region, try Resetting Factory Settings in the Settings > System Settings menu and then select Rest Of World. Maybe your FM will come back.

Sorry, forgot to answer that part–I’m in the US, so “Rest Of World”. Thanks anyway, though. 

Well, if you’re in the US, you should select North America as your Region. And you should have an FM Radio option in the main menu.

Tapeworm, the only options were either “Europe” or “Rest of World”. I should definitely have a radio option, yes! But it’s nowhere on there. 

It’s all the weirder because I left it on radio prior to the update and it was still there immediately after, but with no sound, and very slow changing stations. Once I left the radio option, of course, I couldn’t switch back. 

Tech support is advising me to replace it, but I’d to try everything possible before going that route…

Something’s up . . . .

When you download the firmware, is the bin file in the zipped folder named clpza.bin?  That should allow you to choose N. America for the region.  

If it doesn’t, I’m wondering if something’s happened to the hardware (like the radio fritzing out, physically) causing the player to somehow exclude the N. America option (as the only non-radio versions of the players I’ve heard of have been from outside N. America–if the radio has burned out, the firmware may be sensing the absence of a radio and therefore only be offering non-N. America region options).

That indeed is very weird. Have you tried re-installing the firmware manually?

Yep, I have reinstalled manually once, and the file was indeed called “clpza.bin”. I’m thinking Milkerman is right and the radio must be damaged–probably some residual water from the trip through the wash. 

Oh well–my warranty’s still good. Thanks anyway, guys. 

Well, you have the unfortunate honor to be the first person to post this issue–an odd one, indeed (and sorry for you!).  Good luck with the warranty replacement.

If the radio does not show up, it’s possible that the ClipZip does not see the radio IC.  On the new Zip, the radio control and audio are digital (and we have RDS information to boot!).

Sounds like you may have a hardware issue.

Bob  :dizzy_face:

sounds good to me will come back soon and leave reply…

sounds good to me will come back soon and leave reply…

@malikinam wrote:

sounds good to me will come back soon and leave reply…

Why? Were you even involved in this conversation? :confounded: