FM Radio quit working

This is my second clip, and with both of them the FM radio quit working. The rest of the device seems to work OK – I haven’t downloaded any music of my own. I actually bought the thing for the FM radio. firmware is 2.01.16A. Please help.

Try installing the latest firmware:

The FM radio is just an additional features in the player did you try to listen to the radio in open area where there are good reception, PromisedPlanet provided a link where to update the firmware you can try it and if wont fix the issue you can call Sandisk hotline if it is under warranty you can have it replaced then. :wink:

The FM wouldn’t work no matter where I was. With this second clip, it was fine and just quit while I was listening; I didn’t move anywhere to lose signal. I tried to do the firmware download, following the instructions for the Mac, but it didn’t work. Tried it using XP on VMWare, froze in the updater install. I’m getting frustrated. :frowning:

Do you have the region setting correct?

Settings>FM Settings>FM Region

If you don’t have the correct setting, the tuner won’t be able to find any stations.

What you want to do it get a successful update of the firmware.  Also the Clip needs enough free space to do its magical firmware update.   If its stuffed with songs that maybe an issue.  But its probably something more like corrupted Firmware or corrupted flash content.       So…  Assuming you have a backup of all your music.    Try  Formatting the clip  with its Internal setting menu.  Then be sure to connect it to the Mac in MSC mode.   Download the correct firware   (there is two versions of the clip, be sure to get the correct firmware update.     Un-zip and copy it to the root directory of the Clips/flash device.   Do whatever is recommended to eject/disconnect a Flash device so that it finished the writing of data and closes the connection properly.   Then disconnect the Clip and see how the firmware update goes.    If you get it updated.   For grins  Format the Clip again using its internal - > Settings > format menu.   Test out the FM.  the headphones cord is part of the Clips FM antenna,  Scan for a strong station and see if it works.    

Mac and Linux users can connect their Clip in MSC mode and follow the instructions below.

MSC mode instructions:

  1. Turn on the Clip
  2. Put the device in Hold (move Hold button until orange is showing)
  3. Press and hold the Center Button
  4. Plug the mini-USB connector into the device (be sure the USB is plugged into the computer)
  5. Wait for the Clip drive to mount
  6. Follow instructions below and drag files to the Clip drive


Ensure your battery is > 50% full.

  1. Extract the .zip file into a folder on your computer.
  2. Once extracted, drag the file to the root directory of your Sansa Clip.
  3. Disconnect the Sansa Clip and let it restart.
  4. The firmware update will now begin.
  5. Once it finally finishes doing its update, it will boot back up. Once its back to the main menu, head to “Settings” > “System Info”, and verify the “Version” is now

Do let us know if installing the A firmware causes the radio to work. My guess is it won’t, but it would be nice to know for sure.

If it goes into radio mode tune to a known station. Does the station show on the display? You did not give this info. If the station is shown, does it have a little square under it or a triangle under it? If it is a square, you have paused (muted) the player and will get no sound. Push the >ll button on the ring to get out of pause (mute). This should display a small triangle and restore sound.

Message Edited by 14124all on 08-13-2009 10:47 PM

Well, duh. You hit it! I must have pushed the mute button. :slight_smile:

Now I just have to figure out how to upgrade the firmware. Still having problems with that. But at least I can listen to the radio again! Thanks very much!!!

For upgrading, see the sticky thread on the topic at the top of the forum.

I have a 4gb Sansa Clip which i have used for about 3 years . Lately it seems like even though i have the music on “shuffle” i keep hearing the same few songs over and over. I didnt think much of it because i regularly synch it with either WinMedPlayer or Media Monkey while it is also charging. I have routinely seen an indication at the top of the screen that it is playing , for example, song #633 out of 888 songs. Today i started thinking that in fact it either isnt working properly or i am not successfully downloading enough music.

Somehow in fooling around with it to try to figure out how many songs it actually had downloaded into it, I pressed the wrong button and found myself with the FM radio function. I have never used the radio and dont know that i actually recalled it had this function. I live in the middle of nowhere so radio reception is generally poor.

My problem is that I cannot get this unit out of the FM radio mode and back into playing  my downloaded music! I have tried everything like resetting the whole unit but nothing works. The menu button will only display the FM radio now.\

I looked at the Clip’s properties when i had it connected to my pc and it showed no available space . I also opened it in My PC and it shows plenty of music downloaded onto it.

I wonder if i have simply worn it out. I keep the battery charged fully .I read the user manual and there is nothing i can find in it to help with my problem. 

Thanks for any suggestions on how to get back to my music and turn off the FM radio feature. 

You might try manually reapplying the firmware–it could have become corrupted over time.  See the firmware upgrade sticky thread at the top of the forum.

Otherwise, if that doesn’t work, can you get into the player’s system settings?  You might try reformatting the player from there.  Note:  this will delete your user content–transfer any you want to keep to your computer first.  If you can’t reformat from your player, try connecting to your computer and using Windows to do so.