FM Radio Doesn't Work

I also do have the problem, that my FM radio does not work.

I already went through the existing postings covering this issue and tried a lot of the proposed solutions, but without success.


Product: Clip (black)

Nr. BE0804ASEK

FW: V01.01.35A
Region: Americas 

  1. History:

a) I updated the firmware to  V01.01.35A and the FM radio does not work.

(Unfortunatelly I can not tell whether FM radio worked at all with the original firmware, as I did not use the clip for quite a long time and updated the firmware just to be up to date, without testing the FM radio function befor the update)

b) I updated the firmware as described in one of the postings  with the “a”-extension of the FW file.

c) I restarted the Clip and the installation of the FW went fine.

d) I changed the Settings for the FM radio to “World” and “Stereo”

e) I ran in the radio menu the “Auto-Preset” scan. The progress bar started and completed, but no radiostation was found. (Earphone was plugged in to have the antenna.)

f) I did a manual selection of the FM frequency of a known broadcasting station in the area, but no reception (not even noise; however playing music files works, so earphones etc are working fine)

g) I repeated  steps a)-f) also with firmware extensions “E”, “F” and even “T” and all Region combinations of “Europe”, “world”, “America” with the same negative result.

  1. Questions:

a) Is it possible thet the FM radio receiver hardware module is not implemented in the Clip version I do have?
How can I check this?
Will there be a FM Radio “Auto-Preset” progress bar visible, even there would not be a FM receiver hardware module available in my clip version?

b) As i do NOT use the original earphones , but Sennheiser CX300II with the clip, can it be that this ear phone can for any reason not be used as antenna (shielded cable)? (I can not imagine, why, but you knever know!)

Thanks in advance for any comments.

IIRC some of the European models do not have FM capability at the hardware level, so firmware will not activate it. You could try downgrading to earlier firmware to see if it is a firmware related problem. You could contact Sansa support with the serial number of the unit, they should be able to tell you if it has FM or not.

Hi 14124all,

thanks for your feedback.

I will contact Sansa support as you supposed.

However it seems strange to me that the FM Auto-Preset scan would run in case there is no FM on hardware level.

I would have expected either not to have the FM-radio menue available at all or at least get an error message when running the FM Auto-Preset in case FM is not available on hardware level.

Yes, you are right. I would also imagine that there would be no radio selection in the menu. Try reloading the firmware manually (don’t use updater) and see if it works. If not, it might be a hardware problem.

Hi 14124all,

all the FW updates I already did manually.

In the meantime I contacted the Sansa support and am waiting for the response… 

For whatever it’s worth, it is best to telephone SanDisk for support, if possible–email support can take time.

Hi Miikerman,

thanks for your hint to use telephone contact instead of E-mail.

The first response from Sansa support came within two days which is acceptable for me, as I am not in a hurry. :wink:

I will enter the final result of the ongoing correspondence here as soon as there is one available.

… update of my Sansa support status (Sansa support number-Incident: 100703-000082):

The support could not give me a direct answer to my questions, but asks me to send my Sansa Clip to their depot to get it checked or replaced.

(So I still do not know the way how to check whether an FM radio module is integrated in my Sansa Clip or not,

nor do I know whether a Sansa Clip without FM Radio integratedwould show an FM radio menu and wouldallow to start an FM Radio “Auto-Preset”.)

Message Edited by mahe66 on 07-16-2010 02:49 PM

… Just for information;
In the meantime I downgrade the Firmware from V01.01.35A to V01.01.32a and V01.01.17a, but the FM radio is still not working!

Message Edited by mahe66 on 07-16-2010 03:10 PM

Message Edited by mahe66 on 07-16-2010 03:33 PM

I got a RMA (Return Merchandise Authorization) number from the Sansa support and will send my Sansa Clip to the San Disk RMA Department in Czech Republic…

I 'll keep you informed about the result.

Sansa Clip sent on 21. July 2010.

Waiting for response…

…The Sansa Clip did not reach the support centre yet (02. Aug 2010!)!

I hope the parcel did not get lost in the mail!

I triggered investigations with German Parcel “Deutsche Post” to find out where on the way to the support center it is…

…Originally I only wanted to know how to check on my own whether a FM-receiver is on the Sansa clip or not…

The Sansa Clip did still not reach the support centre in the Czech Republic (05. Aug 2010)!

German Post “Deutsche Post” told me that they have no track of the parcel in Germany and according to the international wold-post-agreement from 2006 it is not mandatory anymore for the Posts to do investigations for simple letters and parcels.
Based on this the Czech Post refuses to do any such investigations.

This means that my Sansa Clip probably disappeared somewhere on the way to the support centre in the Czech Republic.


  • I/we still do not know how to find out whether there is an FM receiver module on a Sansa Clip! Sorry for that!

  • Carry your Sansa Clip personally to the support centre instead of sending it via mail. :wink:

Ah, the mails–very sorry to hear that!


I asked Sansa support to do some investigations from their side where my sansa clip got lost.

In the meantime the clip reached the support centre.

Sansa sent me a replacement clip from the USA on 19.Aug 2010 and reached my home on 25. Aug 2010.

The FM receiver on this Sansa Clip is working !!!

Sansa support -Thank you very much!


  • I still do not know how to check the presence of the FM module on a sansa clip, but my problem is solved now!

  • Never surrender, never give up!  :wink:

@mahe66 wrote:



Sansa sent me a replacement clip from the USA on 19.Aug 2010 and reached my home on 25. Aug 2010.


The FM receiver on this Sansa Clip is working !!!


Hi mate…

By the way… Which firmware version do you have in your new sansa clip…?? I have the same issue with my clip about no FM and I really hate the issue. Already did a lot of Upgrades/Downgrades with no success. I hope you don’t mind to send me a copy of the loaded firmware of your brad new Clip…

Thanks in advance…

Don’t hold your breath . . .

  1. The thread you’re responding to is over a year old, and
  2. you can’t just copy the firmware from one player to another. You should really
  3. Read the responses to your other post that gives you suggestions and a link to an archive of all the firmware versions before posting again in a dead thread.