FM Radio doesn't work

Hi,
I’ve a sansa clip 2GB with the firmware 01.01.20f but the FM Radio doesn’t work at all… If I select “Autoscan for preset” I see the progress bar but at the end no station are tuned. If I try to manual tune some station I don’t hear any sound and some times the clip freeze if I hold the forward button for fast search.
Any suggestion ?

Thank you.


Nothingman

I noted on the packaging of my clip that the model number is: sdmx11n-2048-e70. Is it the version with the radio ? Or they sold me a clip without the radio tuner ?

Thanks again.

Fabio

Did it work with the original FW that came with it?  Did you make sure you downloaded the American (or European version w/ radio) of FW 20?

Unfortunally I didn’t tried the radio before updating the firmware… I’ve tried both with the american version (a suffix) end the european version (f suffix) with no luck.

Now I’ve see that amazon uk sell two model of the clip 2gb black:

  1. Model: SDMX11N http://www.amazon.co.uk/Sandisk-SDMX11N-2048K-E70-Player-Sansa-Black/dp/B000W3LJKU with no radio

  2. Model: SDMX11R http://www.amazon.co.uk/Sandisk-Player-Sansa-Black-Radio/dp/B000W3QTBE with radio.

On the box of my clip the model number is SDMX11N so I suspect it doesn’t contain the hardware for the radio tuner…
The shop where I bought it advertise this model as “mp3 player with radio” so I’ll try to return the player and get back the money…

Thank you.

Glad to see you were able to answer your own question nothingman!  :stuck_out_tongue:  Yes you are right, the “R” or “N” is what identifies the radio option.

:stuck_out_tongue:

I returned the player to the reseller… Now I’ll will search another reseller in Italy;I hope to find one that sell the radio version…

Nothingman