Quit working.

I was in the middle of working out, my clip+ started to play a new song and shut down. Now it will not turn on, will not  respond to any input. Can’t charge it, computer won’t recognize it. It seems to be dead.

The exact same thing happened to me on my run this afternoon. It was fully charged, and now it won’t turn on or respond when connected to my computer.

During a work out my clip fm radio just quit. It connects with the computer just fine and the battery is charged

This just happened to me.  I was playing an audiobook, and I have been listening all day.  The Sansa just stopped.  Won’t turn on, computer won’t recognize.  Yes, mine seems to be dead as well.

Hey!  Mine works again! :)  I think I finally successfully reset it and it woke up.  I had tried the 3 things below as per the user manual.  I guess the last time it just worked for some weird reason.  Another possibility according to the user manual was that just the screen wasn’t working but everything else was.  Who knows?

  1. Went through the motions of forcing it to shutdown, was dead the whole time.  Tried it couple more times, still dead.

  2. Then I tried to force it into MSC mode, still dead.  repeated, still dead.

  3. Tried to reset it several times, still dead.  Did it one more time and I plugged it into the PC( without forcing it into MSC mode) and it just woke up and started working again.

I’m checking for firmware updates as we speak…er - type.

Be sure always to try a reset (original Clip–hold the on-switch uppermost for 15-20 seconds or more; Clip±-hold the on switch down for 20-30 seconds or more).

If the player will turn on or play when connected to the computer but not otherwise it could be a battery lead that has come detached from the battery. 

Stopped working mid song. Full battery. No impact, water damage. Just stopped. Please assist.

See the post prior to yours.

Also try it with the USB cable connected.

Also try forcing a USB connection:  with the Clip off (and on hold if it’s the original Clip), hold the center button down when connecting, and see if that wakens it up. 

Mine has quit working too. It’s only about 7-8 months old. It wouldn’t turn on, so thinking the battery had run down (from showing full the last time I used it), I charged it. It connected to the computer fine, and it could be operated immediately upon disconnecting it, but I couldn’t turn it off. When it’s put on pause and powers down automatically, I can’t turn it on. So far, i’ve tried the following:

  1. Holding down the power switch.

  2. Letting the battery run down completely (letting it play all) and recharging.

  3. Downloading firmware.

4.Connecting to the computer and holding the centre button down.

5.Connecting to the PC and holding the power button down.

So far, none of these has worked. Is there anything else to try? Hope someone can help me fix this, it’s an 8GB Clip+. There’s no extra card in it. Cheers.

You’ve been so diligent, I hate to say it, but:  time to contact SanDisk for a warranty replacement?

Uh, I was hoping you wouldn’t say that…I bought the Clip in the EU and now i’m outside the EU (still in Europe, though), and i’m not sure I still have the receipt , so it looks like it’s going to be a DIY job. I think it might possibly be the power switch has a fault, so i’m thinking it might be worth opening it up and having a look. Any tips? Thanks for the reply BTW.